Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a EIGRP topology set up in GNS3. It looks like this:

The neighbor relationship between R7 and R8 is constantly flapping and I cannot figure out why. Hello timers and time delays are all set properly. I think it must be my configuration. I also sniffed the network traffic in wireshark and it is flooded with ICMP TTL Exceeded packets from R7 destined to R8.

I have tested it as follows:

  • Turning on only R1-R6 = EIGRP Routing working properly
  • Turning on only R7-R9 = EIGRP Routing working properly
  • Turning on ALL Routers = Neighbors flapping and network flooded with ICMP packets

Here are my configs:

#R1
int f1/0
ip addr 172.16.1.1 255.255.255.0
no shut

int lo0
ip addr 192.168.1.1 255.255.255.240
no shut

int lo1 
ip addr 192.168.1.17 255.255.255.240
no shut

int lo2
ip addr 192.168.1.33 255.255.255.224
no shut

int lo3
ip addr 192.168.1.65 255.255.255.224
no shut

int lo4
ip addr 192.168.1.97 255.255.255.224
no shut

int lo5
ip addr 192.168.1.129 255.255.255.192
no shut

int f1/1
ip addr 192.168.1.193 255.255.255.192
no shut

end
conf t
router eigrp 1
network 172.16.1.0 0.0.0.255
network 192.168.1.0 0.0.0.255


#R2
int f1/0
ip addr 172.16.1.2 255.255.255.0
no shut

int lo0
ip addr 192.168.2.1 255.255.255.248
no shut

int lo1
ip addr 192.168.2.9 255.255.255.248
no shut

int lo2
ip addr 192.168.2.17 255.255.255.240
no shut

int lo3
ip addr 192.168.2.33 255.255.255.224
no shut

int lo4
ip addr 192.168.2.65 255.255.255.224
no shut

int lo5
ip addr 192.168.2.97 255.255.255.224
no shut

int f1/1
ip addr 192.168.2.129 255.255.255.128
no shut


end
conf t
router eigrp 1
network 172.16.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255


#R3
int f1/0
ip addr 172.16.1.3 255.255.255.0
no shut

int lo0
ip addr 192.168.3.1 255.255.255.240
no shut

int lo1
ip addr 192.168.3.17 255.255.255.240
no shut

int lo2
ip addr 192.168.3.33 255.255.255.224
no shut

int lo3
ip addr 192.168.3.65 255.255.255.224
no shut

int lo4
ip addr 192.168.3.97 255.255.255.224
no shut

int lo5
ip addr 192.168.3.129 255.255.255.192
no shut

int f1/1
ip addr 192.168.3.193 255.255.255.192
no shut


end
conf t
router eigrp 1
network 172.16.1.0 0.0.0.255
network 192.168.3.0 0.0.0.255

#R4
int f1/0
ip addr 172.16.2.5 255.255.255.0
no shut

int lo0
ip addr 192.168.6.1 255.255.255.240
no shut

int lo1 
ip addr 192.168.6.17 255.255.255.240
no shut

int lo2
ip addr 192.168.6.33 255.255.255.224
no shut

int lo3
ip addr 192.168.6.65 255.255.255.224
no shut

int lo4
ip addr 192.168.6.97 255.255.255.224
no shut

int lo5
ip addr 192.168.6.129 255.255.255.192
no shut

int f1/1
ip addr 192.168.6.193 255.255.255.192
no shut


end
conf t
router eigrp 1
network 172.16.2.0 0.0.0.255
network 192.168.6.0 0.0.0.255


#R5
int f1/0
ip addr 172.16.2.6 255.255.255.0
no shut

int lo0
ip addr 192.168.7.1 255.255.255.248
no shut

int lo1
ip addr 192.168.7.9 255.255.255.248
no shut

int lo2
ip addr 192.168.7.17 255.255.255.240
no shut

int lo3
ip addr 192.168.7.33 255.255.255.224
no shut

int lo4
ip addr 192.168.7.65 255.255.255.224
no shut

int lo5
ip addr 192.168.7.97 255.255.255.224
no shut

int f1/1
ip addr 192.168.7.129 255.255.255.128
no shut

end
conf t
router eigrp 1
network 172.16.2.0 0.0.0.255
network 192.168.7.0 0.0.0.255


#R6
int f1/0
ip addr 172.16.2.7 255.255.255.0
no shut

int lo0
ip addr 192.168.8.1 255.255.255.240
no shut

int lo1
ip addr 192.168.8.17 255.255.255.240
no shut

int lo2
ip addr 192.168.8.33 255.255.255.224
no shut

int lo3
ip addr 192.168.8.65 255.255.255.224
no shut

int lo4
ip addr 192.168.8.97 255.255.255.224
no shut

int lo5
ip addr 192.168.8.129 255.255.255.192
no shut

int f1/1
ip addr 192.168.8.193 255.255.255.192
no shut

end
conf t
router eigrp 1
network 172.16.2.0 0.0.0.255
network 192.168.8.0 0.0.0.255



#R7
int s1/1
ip addr 10.9.0.2 255.255.255.252
no shut

int s1/0
ip addr 119.119.119.1 255.255.255.252
no shut

int f2/0
ip addr 172.16.1.9 255.255.255.0
no shut

int f2/1
ip addr 172.16.2.9 255.255.255.0
no shut

router eigrp 1
network 10.9.0.0 0.0.0.3
network 119.119.119.0 0.0.0.3
network 172.16.2.0 0.0.0.255
network 172.16.1.0 0.0.0.255
end



#R8
int s1/1
ip addr 10.11.0.2 255.255.255.252
no shut

int s1/0
ip addr 119.119.119.2 255.255.255.252
no shut

int f2/0
ip addr 172.16.2.11 255.255.255.0
no shut

int f2/1
ip addr 172.16.1.11 255.255.255.0
no shut

router eigrp 1
network 10.11.0.0 0.0.0.3
network 119.119.119.0 0.0.0.3
network 172.16.2.0 0.0.0.255
network 172.16.1.0 0.0.0.255
end


#R9

int s1/1
ip addr 10.9.0.1 255.255.255.252
no shut

int s1/0
ip addr 10.11.0.1 255.255.255.252
no shut

router eigrp 1
network 10.9.0.0 0.0.0.3
network 10.11.0.0 0.0.0.3
end

I believe it must be an error in configuration but I cannot find it. Any help would be greatly appreciated.

share|improve this question
    
Are you able to ping from R4 to R1? Is there high CPU on R7 R8 or R9? –  GerryEgan Jan 21 '13 at 23:52
    
there is High CPU on all router except R9. Pinging does not work from any of the bottom routers to any of the bottom routers or R7 or R8. When the network first converges the whole network pings properly but after time I suspect the network is so flooded that pings cannot get through. –  Cheesegraterr Jan 21 '13 at 23:58
    
If you configure 'no auto-summary' and 'eigrp log-neighbor-changes' under each of your EIGRP processes, what does the log file say about the neighbors flapping? –  cpt_fink Jan 27 '13 at 1:16

2 Answers 2

You're running a discontinuous classful network 172.16.0.0 / 16 in two network portions. In this particular case, auto summarization will make your routing table inconsistent by summarizing the network above and advertising it to the other side and vice-versa.

Try adding no auto-summary to your eigrp settings on ALL routers so that the final configuration looks like:

    router eigrp 1
     no auto-summary
     network x.x.x.x
share|improve this answer
up vote 2 down vote accepted

After hours of testing... the problem was found to be a corrupt IOS image. I swapped the image with an older version and all my original configs are working correctly. DOH!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.