Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been hit by the bug (restarting iptables ignores values in /etc/sysctl.conf). This bug has been fixed by RH quite a while ago.

The server has had yum update run many times since the RH fixed this bug. The lastest run, yum said everything was updated. However that's obviously not the case since when I restart iptables, the value net.ipv4.netfilter.ip_conntrack_tcp_be_liberal gets set to 0, ignoring what is in /etc/sysctl.conf

The solution in the bug is to apply a patch that fixes /etc/rc.d/init.d/iptables and /etc/sysconfig/iptables-config. I've tried the patch and it does fix the problem

However I'd like to make yum fix this so I reverted the files in question. I've tried yum update and yum install iptables (that package provides both of the files in question) but it doesn't fix the problem.

What can I do to make yum get the correct files installed from the iptables package?

Thanks in advance.

share|improve this question

The bug you linked was closed as a duplicate of bug 552522.

That bug then links to RHBA-2012:0255-1, which states the issue was fixed in iptables-1.3.5-9.1.el5. Unfortunately, you didn't tell us what version of iptables your system has installed, so you'll have to do the comparison yourself. Make sure you have actually installed this or a later version.

share|improve this answer
I've done yum update several times so it should be whatever is the latest version for RHEL 5.9. – Jistanidiot Jan 29 '13 at 16:04
up vote 0 down vote accepted

The solution seems to be in /etc/sysconfig/iptables-config to uncomment the line IPTABLES_SYSCTL_LOAD_LIST=".ip_conntrack .bridge-nf"

Of course this only works if the patch has been applied.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.