Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am looking for a way to monitor individually the disks an array on a ServeRAID device using smartctl. The RAID is seen as a single disk /dev/sda by Ubuntu 12.04 LTS. The ServeRAID is a ServeRAID - 5i (adaptec) from an IBM eServer serires x345 with SCSI disks.

I've tried various ways with smartctl, as it could be done with 3ware RAID. I also browsed the web and saw people monitoring through /dev/sgX entries. But those attempts were unsuccessful.

The idea behind this is to be able to monitor each disk of the array for SMART to be able to have data for Munin, Icinga and smartd.

Any solution?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You don't tell us what kind of system this is on, but if you can install IBM Director SNMP agents on it you can monitor the controller via SNMP.

It's not smartctl, but the ServeRAID MIB is quite comprehensive and includes both physical and logical device status information. if you have a monitoring system in place that uses SNMP this would be my choice.

share|improve this answer
What extra info do you need? And I'd like to prevent SNMP usage to keep disks monitoring methods consistent. – Heis Spiter Jan 22 '13 at 18:33
I don't need any extra information - If you want to pursue this option you need to determine if your hardware and software are supported by IBM's Director utilities... – voretaq7 Jan 22 '13 at 19:01
I guess I won't have other choice than going for it. Thank you. – Heis Spiter Jan 24 '13 at 7:24

If the controller supports it, you can use the -d option on smartctl to get access to the underlying devices:

smartctl -a -d megaraid,0 /dev/sda

Increment the 0 to access each drive in the array.

share|improve this answer
I believe ServeRAID controllers play nicely with the -d option. – voretaq7 Jan 22 '13 at 18:21
Unfortunately, it doesn't. This method doesn't work. Smartctl open device: /dev/sda [megaraid_disk_00] failed: cannot open /dev/megaraid_sas_ioctl_node or /dev/megadev0 – Heis Spiter Jan 22 '13 at 18:32
Do some research on the -d option. You might need something other than megaraid. – longneck Jan 22 '13 at 18:50
I've tried some others without success. Including areca, 3ware, megaraid, cciss. – Heis Spiter Jan 22 '13 at 19:00
I've done a bit of searching and I don't see any evidence of people with ServeRAID-5i controllers being able to use smartctl. Sorry. I don't think it's possible. – longneck Jan 22 '13 at 20:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.