Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Update: I configured putty (Windows 8; x64) to send exactly the same data as an old 16 bit Hyperterminal (Windows XP). I tested it using Wireshark. But still the Software on the Suse Server does not respond correctly to my typing of Fn keys.

What could possibly be wrong? Wat am I missing here?


I just switched from a 16 bit terminal client to Putty (on Windows 8 Pro x64) and ran into a Problem which I cannot solve on my own:

I need the Keyboard shortcut [Shift]+[F1] inside the Server-Session. But whenever I type the two keys, Putty just removes the selected character form the screen.

Wireshark told me the transmitted Data is "\033[Y" and the "Poor Woman's Telnet Server" (ShellIo Java Library) calls it "Unrecognized ESC sequence with char 89 Y".

How can I send this escape sequence from the putty client? I configured putty to SCO Keyboard Settings and it sends the right sequences (so it's shown in Wireshark). But the Server does not respond to F1 to F12.

share|improve this question
    
Do a packet capture using the old client, figure out exactly what key sequence is sent when you press shift-F12? Then configure Putty to do that? We can't really help you given the information you have posted so far. You haven't told us anything about the software/OS that you are connecting to. –  Zoredache Jan 22 '13 at 22:59
1  
It seems that the original Client sends [ESC]+[ ]. What is this in putty? Or can I map another key to this combination somewhere? –  Myrad Jan 22 '13 at 23:09
    
May be it was [[]+[Y] instead. How can I type this? –  Myrad Jan 22 '13 at 23:15
    
No idea. But you can/should edit those details and questions into your question. Did you find that information through a capture, or from some documentation? You might also want to consider adding details about the HOST OS, and software you are using, if it isn't something custom. –  Zoredache Jan 22 '13 at 23:19
    
I will expand my question after work tomorrow, maybe I can read something using wireshark. The informations above are from the old Client configuration. –  Myrad Jan 22 '13 at 23:23

1 Answer 1

try following: Configuring PuTTY

share|improve this answer
    
Thanks, but I read this page over and over and tried everything useful (as far as I can judge). Putty now runs in the Xterm R6 mode, so far the only one fully compatible with the server software. –  Myrad Jan 22 '13 at 22:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.