Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to use puppet to install apache and enable some modules so I installed the puppetlabs/apache module and tried to use it.

Apache installs fine but the modules aren't enabled at all. I tried it like it is described in the readme

class { 'apache': }
class { 'apache::mod::ssl': }
class { 'apache::mod::fcgid': }
class { 'apache::mod::suexec': }

and also like this

include apache
a2mod { "Enable ssl":
    name => "ssl",
    ensure => "present"
}
...

Neither are the modules installed (libapache2-mod-fcgid, apache2-suexec) nor are they enabled.

Server is Ubuntu 12.04

UPDATE: --debug output

/Stage[main]/Apache::Mod::Suexec/Apache::Mod[suexec]/Package[apache2-suexec]/require: requires Package[httpd]
/Stage[main]/Apache::Mod::Suexec/Apache::Mod[suexec]/Package[apache2-suexec]/before: requires A2mod[suexec]
/Stage[main]/Apache::Mod::Fcgid/Apache::Mod[fcgid]/A2mod[fcgid]/require: requires Package[httpd]
/Stage[main]/Apache::Mod::Fcgid/Apache::Mod[fcgid]/A2mod[fcgid]/notify: subscribes to Service[httpd]
/Stage[main]/Apache::Mod::Suexec/Apache::Mod[suexec]/A2mod[suexec]/require: requires Package[httpd]
/Stage[main]/Apache::Mod::Suexec/Apache::Mod[suexec]/A2mod[suexec]/notify: subscribes to Service[httpd]
/Stage[main]/Apache::Mod::Ssl/Apache::Mod[ssl]/A2mod[ssl]/require: requires Package[httpd]
/Stage[main]/Apache::Mod::Ssl/Apache::Mod[ssl]/A2mod[ssl]/notify: subscribes to Service[httpd]

UPDATE: required packages for fcgid and suexec are installed now and the fcgid mod is even enabled, but suexec and ssl mods stay disabled.

share|improve this question
1  
Do you have the dependencies setup so that Apache is completely installed before you try to enable the module? Are you getting any errors? If you run the puppet agent with the --debug option, what you see related to the a2mod? –  Zoredache Jan 23 '13 at 1:10
    
added debug output into the main question. there are no errors or other A2mod related outputs. –  Dehalion Jan 23 '13 at 1:38
add comment

1 Answer

up vote 0 down vote accepted

I ran into the same problem and finally gave the example42/apache module a try instead. Works like a charm.

In my case:

class { "apache": }

apache::module { 'ldap':
        install_package => false,
}
share|improve this answer
    
yeah, did it for me too... –  Dehalion Apr 4 '13 at 20:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.