Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently created a small office network with 10+ computers. 9 of them are desktop computers so I used Ethernet cable to connect them.. The computers are connected to a switch via a patch panel and to a wifi router for internet access. All of these computers are connected to the same work group and sharing public files are enables. all sharing functions are enabled and every one can see each others computers over the network.

But the issue is with the one laptop that is connected over wifi to the network. The laptop lists some of the desktop computers that are in the LAN but not all. I used run command and gave the path to a non listed computer and it shows up very well. but the thing is, I need to list all the computer in the network places.

what should I do to this issue.

Laptop OS : windows 7 wifi router : dlink

stock settings with wifi password.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

If I understand your question correctly it sounds like you are having an issue with Windows Network Discovery.

First things first, can you confirm that you can connect to shared resources such as a file share or print share of the non-listed computers via a UNC path from the laptop and then back from the non-listed computer to the laptop.

I'm assuming you are not on a Windows Domain and are using Workgroups.

  • Make sure all the machines are in the same Workgroup.
  • Make sure Network Discovery is turned on and the firewall is configured appropriately on the computers that are not be enumerated by the laptop.
  • Be patient, Microsoft says that it can take up to 15 minutes for shared resources to be detected via Network Discovery.
  • Ensure that your D-Link All-In-One-Device is not filtering or otherwise blocking connections between the wired and wireless segment in such a way as to prevent Network Discovery from working properly (without knowing your subnetting or firewall setup I can't be more specific)
  • Verify that whatever name resolution service you are using for your Workgroup is functioning appropriately.
  • Verify that the, DNS Client, Function Discovery Resource Publication, SSDP Discovery and UPnP Device Host services are running on both the unlisted machines and the laptop.
  • Make sure all your machines are using the appropriate network profile (Public, Private, Work).
share|improve this answer
add comment

There are certain things that you should configure in order to successfully overcome the problem.

  1. You need to configure the WiFi router. Default configuration is not recommended. It is not secure as well. You need to configure the router with WPA2 security. Using WEP is not recommended. And it is not secure. Windows 7 and later versions support WPA2.
  2. Enable network discovery from Network and Sharing Center. First enable both for public and private networks. For better security, you can stop SSID broadcasts and enable MAC filtering (still it does not mean you can ensure that the security reached 100%. Just hardening the security is always better.
  3. With LLMNR and Link-Layer Topology Discover Mapper (enable service with services.msc), you should be able to see a network map in network and Sharing Center. However, router should support. D-link routers do support such features.
  4. If a firewall is in place (third party or configured Windows Adv Firewall) you should not block File and Print Sharing ports.
  5. Check the requests and responses using Wireshark and with the captured files its possible to check name resolution issues. Check ARP cache as well.
share|improve this answer
1  
Come on ... MAC filtering is useless, and broadcasting blank SSID actually reduces security, because the client will broadcast probe requests with the SSID in plain text everywhere just to be able to detect the AP. This opens the possibility for hackers to actually bruteforce the passphrase used by the client, wherever it is. And otherwise, it is as useless as MAC filtering anyway. –  BatchyX Jan 23 '13 at 10:29
    
@lasith : I have enabled all the sharing options in the laptop as well as all the desktop PCs in the LAN. The desktop PCs have a perfect network map and they can access all of the shared folders perfectly. The issue is with the laptop.. And the Wifi is PW protected. I meant all the other options by default. A third party firewall can be the culprit cus, kaspersky is running. Can you state any ports and protocols I should allow from the firewalls. –  Dimal Chandrasiri Jan 23 '13 at 12:56
    
@BatchyX I am aware of that quite well. You are not taking WPA2 Enterprise Security in to account. It is not the same as WEP. It requires more sophisticated attacking method even if detected. Better to check the entire post. Just for a test scenario. @ Dimal Chandrasiri. Kaspersky can be a problem. Make sure the firewall lists the Wireless network as trusted (full trust). If possible, allocate the network address ranges to trust (its possible to provide more information, however, not clear of the specific version you have). Make sure network profile are "Work". Thank you! –  Lasith Jan 23 '13 at 19:57
    
Additionally, ports can be found by looking and Windows Firewall. There are several ports that you need to pay attention. You can disable the security system and check to confirm that the issue is caused by the Kaspersky suit. –  Lasith Jan 23 '13 at 19:59
    
@Lasith: I have took RSN/WPA2 into account. Still, someone seeing these probe requests can mount a fake AP and can hope to retrieve a EAPOL 3/4 from the client, which is what a normal AP uses to check the password. The fake AP can fetch it and bruteforce it offline (except when SAE is used, but who knows SAE ?), hoping to break medium/weak passphrases. But anyway, adding useless security to already strong security is even more useless, it adds more trouble for absolutely nothing. –  BatchyX Jan 23 '13 at 22:11
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.