Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was just transferred to a new factory and there is this issue that keeps popping up and the error says "There are no more endpoints in the endpoint mapper." This error occurs when trying to rejoin a computer to a domain. We have these XP embedded thin clients and they are the only machines that have problems. Has anyone else ever seen this issue? I've tried staging the computer in AD after deleting the object and no luck, I've also tried restarting the RPC services but that yields nothing either. The one thing that I find strange is that these machines dont have RPC Enpoint mapper they only have RPC and RPC Locator.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

We had this issue with a ISA 2006 box that it couldn't connect to a specific forest in a 2 way forest full-trust.

We never did find a solution but now believe it was down to Symantec endpoint firewall that was installed and some of the flood DoS protection built into ISA needed disabling.
(It was one of the engineers installed the endpoint protection for AV etc but didn't think to disable the firewall aspect #fail) In the end we got fed up of troubleshooting that we rebuilt the box and left it bare minimum

Hope this helps!

share|improve this answer
    
Unfortunately thats what I've been doing to but occasionally the error comes back after reimaging the machines which is quite frustrating. I'll look into the symantec fix though! –  Alex Manley Jan 23 '13 at 16:26
    
reimaging? Are you cloning or doing like a full sysprep'd and generalised image? –  Aceth Jan 23 '13 at 16:29
    
I've met so many people who just do a full clone of machines, not realising the whole importance of SID relations with Active Directory etc. –  Aceth Jan 23 '13 at 16:30
    
they are thin clients so you pop a flash drive in and it just takes it and my coworker thinks that the SID relations are getting corrupted some how. –  Alex Manley Jan 23 '13 at 16:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.