Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am attempting to SSH into a virtual IP on a loadbalancer. I want to connect to this virtual host name and have it connect me to one of the virtual hosts. The problem is when I try to ssh to the virtual IP, one of the actual IPs respons (reseting my connection).

Is there a way to configure the network to allow an ssh connection to the virtual host-name and have it connect me to one of the hosts?

eg network: 192.168.0.3 -- server-cluster01 - .4 -- server01 - .5 -- server02 - .6 -- management

Managment's host file contains the entry for the server-cluster01.

From managment box:

root@managment~: ssh server-cluster01

From the monitoring tools I get

192.168.0.6 -> syn 192.168.0.3
192.168.0.4 -> ack 192.168.0.6
192.168.0.6 -> rst 192.168.0.3
(repeat)
share|improve this question

2 Answers 2

This handshake should look similarly wrong for any TCP connection to the cluster, not specifically for ssh. (And in fact the same problem should occur for udp). Can yuo confirm (by sniffing) that other (working) services continue the handshake with the virtual address or with one of the member addresses?

(Sorry, this should be a comment, but I can't)

share|improve this answer
    
I will check this out. Why does ICMP work then? –  Jeff Jan 23 '13 at 16:48
    
What ICMP works? –  David Schwartz Jan 23 '13 at 18:51
    
The solution is to use NATing, which we didn't think would be an option at the time. –  Jeff Jan 24 '13 at 15:23
up vote 0 down vote accepted

The only solution I can see is to use NAT. The solution is similar to the solution I use at home (technically PAT I think) with port forwarding. I am able to SSH into a public IP which then forwards my traffic to a private IP.

I wish there was another solution other than NAT, but I don't see one. I'll keep the question open for a bit in case someone can offer a new solution.

share|improve this answer
    
IPv6, of course. :) –  Michael Hampton Jan 25 '13 at 17:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.