Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to move a container to a different filesystem, specifically a subdir of an already mounted LUKS/dm-crypt home dir. I tried moving it there and then bind mounting or symlinking it to /var/lib/lxc/foo but when I do lxc-start -n foo just exits immediately.

Debugging output just says lxc_start - container init process exited and lxc_error - child <30146> ended on error (1). I get no output from upstart even with lxc-start -n foo /sbin/init --verbose so it looks like /sbin/init is exiting before it does anything. I get the same if if I symlink the whole /var/lib/lxc dir into the dm-crypt home and do a lxc-create for a totally fresh container but it works just fine if the container is symlinked from the same filesystem.

How can I move the container to the dm-crypt home dir such that it will run?

This is on Ubuntu 12.10 using sudo lxc-create -n foo -t ubuntu.

share|improve this question
Why not just mount the encrypted filesystem there? – Michael Hampton Jan 24 '13 at 20:54
@MichaelHampton I want a subdir of the already mounted home dir to be the container. – Ross Patterson Jan 24 '13 at 21:00
up vote 0 down vote accepted

The issue was the mount options used. Because I was using pam_mount and some copying and pasting I had the nodev and nosuid options on. Once I took those out, it worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.