Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set up vsftpd on numerous Ubuntu boxes without any problems, but in this particular case I am having a heck of a time getting it to work for some reason.

When I attempt to connect from another computer using FTP it allows me to enter a username and password, but then immediately responds with "500 OOPS: Connection closed by remote host."

I have tried many different configuration settings and always have the same result. Also after disabling the firewall completely. Nothing appears in the log file other than:

Thu Jan 24 15:00:24 2013 [pid 2] CONNECT: Client ""

Where of course is the address of the computer I'm connecting from. No actual errors to speak of.

I can't seem to find any instance of anyone having this exact problem. Suggested solutions to other similar problems have no effect. Can anyone offer some suggestions regarding things I might not be considering?

And any more information I should provide, just let me know. Thanks in advance!

share|improve this question
up vote 1 down vote accepted

Here was the solution:

Basically comment out

auth required

in /etc/pam.d/vsftpd

Was able to track that down after tailing auth.log. I hope there aren't serious downsides to this but at least it got me back in business today.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.