Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am at a complete lost as to what to do about this, using IIS is very new to me so bare with me, I am trying to get my site to show up on the localhost, I have asp and asp.net installed in windows features and IIS does seem to work, however the problem is when I go to the site itself on the localhost I get this error

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

and then under it says

Config Source

   -1: 
    0: 

Now I know the problem may be inside of the web.config file which is listed here...

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <defaultDocument>
            <files>
                <add value="index.asp" />
            </files>
        </defaultDocument>
    </system.webServer>
</configuration>

what can I do to try to fix this? also ive upload a screenshot.

Any help is greatly appreciated.

enter image description here

Full image

share|improve this question
    
So is your site asp or asp.net? –  levelnis Feb 1 '13 at 10:48
    
Asp, I was able to fix the problem, it seems that the users wasn't added into the permissions as I thought it was. –  Jeremy Love Feb 1 '13 at 18:35

1 Answer 1

This is probably caused by ACLs preventing the IIS process from accessing the config file. Make sure the account that the application pool is running under has read access to everything in the folder containing the website.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.