Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My 2-year old mail server started crashing with BSOD about 2 months ago, and every time you check memorydump it says "Probably caused by : iaStor.sys ( iaStor+4b676 )".

Initially it ran with Intel Storage manager version 8.6, then I upgraded to 8.8, today it's at 8.9, still same problem.

Server is Tyan, out of warranty. Latest BIOS.

Windows Update is not working right now, but should be fairly up to date.

RAID is 1 (main data) and 0 (backup), 4 750GB drives total.

It runs Exchange 2007, Sharepoint v3 and Backup Exec V12.5.

As far as I know nothing changed - no drivers, no software, no hardware. I tried updating everything I could find (software-wise), no dice.

Everytime it crashes like that Intel starts rebuilding the Mirror. Data doesn't seem to be affected.

Server can go as little as 1.5 hours and as long as 1 week between crashes. Last data is 15 BSODs in a month.

Tried researching via google, via intel's site, tried disabling 1 USB which had same IRQ as Intel controller, updated BIOS, nothing.

Any ideas?

Thanks!

share|improve this question
    
Which Tyan server product are you running? Are you running hardware RAID (PCI-e/PCI-x/PCI) or off an on-board controller? –  osij2is Jul 28 '09 at 21:36
    
Tyan Tank GT20 tyan.com/product_barebones_detail.aspx?pid=367 It's an on-board controller. –  Dami Jul 29 '09 at 15:11

3 Answers 3

up vote 0 down vote accepted

What OS are you running? 2003? 2008? SBS?

Just off the top of my head, it could be:

  • Driver issue: corrupt driver? Maybe rollback to a previous version?
  • BIOS setting: can you look at the storage controllers setting at boottime (assuming you have hardware RAID). Maybe there's a setting that needs adjustment.
  • Bad disk: I doubt that the hard drives are bad, but it wouldn't hurt to check or do some sort of disk scan offline and see what's what. Eliminate this option.
  • SATA/SAS wiring: I don't know which exact controller you use or bus type, but maybe (and it's highly unlikely) there's something wrong with the SATA/SAS wiring. Frayed maybe?
  • I/O port: try switching the physical cables/ports to see if it's a specific problem with the interface. Again, another uber-rare issue, but I've had this happen before.

Hope this helps. Please add more detailed information as that might help clue us in on what the problem may be.

share|improve this answer
    
Thanks for a quick reply. - OS is Win2003 x64, it says so in the subject. - TYAN BIOSes are very feature-rich, tried tinkering with BIOS before, no dice. - Can't do offline scan, it's a production server and it'll take it down for a good chunk of time. Scanned the RAID0 part though, no errors - It's a built-in RAID controller, it's intel chipset with controller. Server is Tyan Tank GT 20 (tyan.com/product_barebones_detail.aspx?pid=367) - There're specific ports on the board, which correspond to specific drive number. 4 drives, 4 ports. I could switch them around, doubt it'll help. –  Dami Jul 29 '09 at 15:10
    
I just read quux post; it looks awfully close to your exact problem ( SCSI port driver issue that is). I can't believe I didn't even look for the OS in the header. Go figure. Oh, and 4x 750gb drives - I have to assume SATA. I've got a lot of experience with Tyan, but less when it comes to Intel-based solutions. I would try making one change at a time to see what is the cause. I'm looking into the specs right now. I'll see what I can dig up. –  osij2is Jul 29 '09 at 15:22
    
Ok, so while being a huge Tyan fan, this board does NOT use real RAID. Sorry but the on-board Intel 5100/ICH9R isn't hardware level RAID. For whatever reason, in my experience onboard RAID eventually fails and dies. Buy a true hardware RAID solution from 3Ware, Adaptec, Areca, etc. etc.. This is exactly why I'm against on-board RAID solutions. My suggestion from this point would be to ditch the on-board controller and get a PCI-e RAID controller. 4-port solutions aren't too pricey and most of the server market manufacturers include LP (low profile) brackets to fit 1U/2U solutions. –  osij2is Jul 29 '09 at 15:30
    
I just read my post and wanted to apologize if it sounded like I was scolding you or being derogatory. I meant no disrespect by it. I realize that I didn't even ask if you had a budget or any means of buying/transplanting a newer RAID controller so again, if it were up to me, I'd buy 4-port SATAII RAID PCI-e controller and ditch the on-board controller. I guess I get bothered by the fact that manufacturers still embedded supposed RAID solutions on-board, but they never last and always seem to cause more problems then they solve. Anyway.. my apologies for my previous post. –  osij2is Jul 29 '09 at 15:35
    
osij2is, no offense taken - I actually did not know that ICH9R is not a true hardware RAID. I'll discuss that with my guys, I should have no problem replacing it, except that I think both RAIDs won't port to new controller? Rebuilding server would be PITA, especially when Exchange 2010 is around the corner, I was planning on upgrading to win2008 with ex2010 next year. –  Dami Jul 29 '09 at 15:42

I have some Tyan's (actually they're the same as yours) with iastor.sys issues. Memory leak in the driver killing the non-paged pool. Try removing the Intel Matrix Storage Manager and see if that fixes your issue. It did for me.

share|improve this answer

Assuming you have Windows 2003 and you're getting this error verify you have Service Pack 2 installed, or request and install this hotfix.

share|improve this answer
    
Thanks quux. Indeed, the error I'm getting is exactly the same. I checked and I do have SP2 installed, I verified file versions and they're different from what the hotfix page says 5.2.3790.2529, I have 5.2.3790.3959. Tried reinstalling SP2, same file version, will see if it crashes again. Any other ideas? –  Dami Jul 29 '09 at 15:00
    
Sorry, no. Haven't seen the issue myself - but the article mentioning iaStor.sys had come up in one of my own technet searches lately. You're probably down to contacting MS and/or Intel. Good luck! –  quux Jul 30 '09 at 0:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.