Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed the instructions at https://help.ubuntu.com/community/PostfixCompleteVirtualMailSystemHowto to setup a smtp and imap server on my local network.

But when i try to login with thunderbird (after creating mailbox with postfixadmin) I get a "Password or user name wrong error.

this is the tail of /var/log/mail.err

Jan 26 04:18:15 NightHwack imapd: Connection, ip=[::ffff:192.168.1.4]
Jan 26 04:18:15 NightHwack authdaemond: received auth request, service=imap, authtype=login
Jan 26 04:18:15 NightHwack authdaemond: authmysql: trying this module
Jan 26 04:18:15 NightHwack authdaemond: authmysqllib: connected. Versions: header 50517, client 50529, server 50529
Jan 26 04:18:15 NightHwack authdaemond: SQL query: SELECT username, password, "", '5000', '5000', '/var/mail', "", "", name, "" FROM mailbox WHERE username = 'webmaster@xincoz.com' 
Jan 26 04:18:15 NightHwack authdaemond: password matches successfully
Jan 26 04:18:15 NightHwack authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/mail, address=webmaster@xincoz.com, fullname=Webmaster, maildir=<null>, quota=<null>, options=<null>
Jan 26 04:18:15 NightHwack authdaemond: authmysql: clearpasswd=<null>, passwd=$1$e7d3bbc2$zWm3PmkfdCHAbz.kyRPld/
Jan 26 04:18:15 NightHwack authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/mail, address=webmaster@xincoz.com, fullname=Webmaster, maildir=<null>, quota=<null>, options=<null>
Jan 26 04:18:15 NightHwack authdaemond: Authenticated: clearpasswd=webmaster007, passwd=$1$e7d3bbc2$zWm3PmkfdCHAbz.kyRPld/
Jan 26 04:18:15 NightHwack imapd: chdir Maildir: No such file or directory
Jan 26 04:18:15 NightHwack imapd: webmaster@xincoz.com: No such file or directory

Folders in /var/mail/

webmaster 
root 
agent

please help me resolve this. Thank you :)

share|improve this question
    
Your postfix is complaining about your Maildir being non existent. Can you post your postconf -n? –  fboaventura Jan 26 '13 at 3:30
    
her eis my postconf -n output pastebin.com/JpdNQC8r –  blas Jan 26 '13 at 6:17

1 Answer 1

You missed the postfix configuration for use with virtual domains and users.

# Virtual Mailbox Domain Settings

virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql_virtual_domains_maps.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf
virtual_mailbox_limit = 51200000
virtual_minimum_uid = 5000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_transport = virtual

There are other configurations you must check, as user creation and directory permissions. These configurations are in the section 12 of the tutorial you are following.

share|improve this answer
    
The lines mentioned above seen to be present in the ,main.cf –  blas Jan 26 '13 at 15:03
    
Also I notice that the mailboxes is being created in /var/mail than in /home/vmail : although both postfix and courier config says /home/vmail is the folder –  blas Jan 26 '13 at 15:16
    
I didn't saw the lines in your postconf output. Can you post your main.cf then? –  fboaventura Jan 26 '13 at 18:09
    
sure here is the main.cf file pastebin.com/LA3mkewX –  blas Jan 26 '13 at 18:20
    
Found a syntax error on your main.cf. Line 27 there is a parameters loose there, remove it and you may be good to go. By the way, the command to check for syntax is postfix check. –  fboaventura Jan 26 '13 at 18:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.