Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hello I successfully set up my Redmine server (Ubuntu 12.04LTS, Apache2, Passenger, Mysql using the guide at http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_Ubuntu ). However I have encountered a small problem. I would love to enter the internal ip adress of my server into the address bar of the browser and visit the site but I must enter ip_address/redmine and I can not portfoward the router to that. Currently if I use my website www.example.net or ip_address in the browser I get the default apache2 "it works"(index.html) page.

I'm including my config files as I have not found other examples using the same set up just ask for more config files if you need them. Also if there is any extra unneeded stuff in them please tell me so I can remove it

this is my ports.conf file:

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>

this is my 000-default file found in /etc/apache2/sites-enabled/

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www   
<Directory /var/www/redmine>
        RailsBaseURI /redmine
        PassengerResolveSymlinksInDocumentRoot on
</Directory>

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

for some reason httpd.conf is empty

share|improve this question
    
Try change RailsBaseURI /redmine to just / –  aardvark Jan 26 '13 at 9:03
add comment

1 Answer

You are using Passenger to serve a Rails application.

Try to change your document root:

DocumentRoot /var/www/redmine/public   
<Directory /var/www/redmine/public>
    Allow from all
    Options -MultiViews
</Directory>

Of course reload the Apache service.

If this is not enough please read the Passenger documentation to publish on a virtual host root: http://www.modrails.com/documentation/Users%20guide%20Apache.html#_deploying_to_a_virtual_host_8217_s_root

share|improve this answer
1  
Welcome to Server Fault! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. –  slm Apr 17 '13 at 0:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.