Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I feel a bit lost, after installing apache with suexec on ubuntu12.04 on url click I'm prompted to download the page the message what I get a message what shows the following You have chosen to open which is: application/x-httpd-php (395 bytes)

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Make sure that, along with the Apache package, you've installed the PHP package and configured Apache to use PHP for .php files.

share|improve this answer
3  
Specifically, make sure you have a handler for the application/x-httpd-php MIME type. There should be a SetHandler directive in your configuration that implements this; it will usually be enclosed in an <IfModule mod_php5.c> block. You'll also want one for application/x-httpd-php-source. –  Andrew B Jan 27 '13 at 1:14

It sounds like you either don't have mod_php installed, or you don't have it enabled in Apache.

sudo apache2ctl -M | sort should show you the currently running modules. The PHP module should be in there. If it's not, follow one of the thousand guides for installing it on your OS.

share|improve this answer
    
under loaded modules I have php5_module(shared) –  fefe Jan 27 '13 at 0:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.