Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Not sure if this post belongs here, but:

Does anyone know why the desktop and over all icon quality in server 2008 is so much lower compared to 2012 when using RDP? And if it can be changed? VNC shows icon quality in Server 2008 as if you were looking at the machine with a console.

I appreciate it's a remote connection but just curious.

Here are some images to show you what I mean.

2008:

https://www.dropbox.com/s/ujyum3vrvp88snx/2008.png

2012:

https://www.dropbox.com/s/0kthbcexzbpqhjz/2012.png

Cheers guys.

share|improve this question
    
2008 probably just defaults to a lower screen resolution for RDP sessions. See if you can change it in the normal way. –  EJP Jan 27 '13 at 22:36

1 Answer 1

Before you launch an RDP session you can choose what Color Depth you are using as well as the resolution. Ensure before you launch your RDP session that you are on a Highest Quality (32 bit) Color Depth. And Also check the Experience tab on your Remote Desktop Connection Application and manually check all the options you want instead of letting it automatically decide.

share|improve this answer
    
I have tried a number of different preferences from what you mentioned above. However there is no change from what I can see. Does server 2008 use alternative low res icons when connecting via RDP instead? –  user155551 Jan 28 '13 at 2:10
    
Did you already try adjusting the color depth and resolution inside the RDP session on 2008? –  Kentgrav Jan 28 '13 at 11:49
    
Do this. RDP into your Windows 2008 machine. Right click on the Desktop. Select Personalize. Select Display Settings. Click the Drop down under Colors and select Highest (32 bit). Let me know if it changes then. –  Kentgrav Jan 28 '13 at 13:46
    
Hey man, Not quite sure how to achieve this, as I am promoted with a banner saying 'The display settings can't be changed from a remote session'. :s To add this is a VPS I am connecting too and I have RDP from a Mac and a Windows machine to test with. –  user155551 Jan 28 '13 at 21:10
    
Do you have administrative rights on that machine? I just tried it with my own Win 2008 Server and I replicated exactly what you had and fixed it by changing the color. –  Kentgrav Jan 28 '13 at 21:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.