Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed nx & freenx on a RHEL 6.3 via the 'yum install nx freenx' command. In the configuration file, node.conf, I've un-commented the following lines:

ENABLE_USERMODE_AUTHENTICATION="0"
ENABLE_PASSDB_AUTHENTICATION="0"
ENABLE_SSH_AUTHENTICATION="1"

On my mac client I have installed the NoMachine player and copied the client.id_dsa.key from the server. On the server I am able to successfully start the nxserver via the nxserver --start command. When I run nxserver --status I get the following output:

NX> 100 NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: not detected)
NX> 110 NX Server is running
NX> 999 Bye

So to me it means that the nexserver is running and indeed I'm able to telnet into the port. THe problem is that when I try to connect using my NoMachine client I get the following error almost instnantly:

The NoMachine service is not available or the NX access was disabled on host xxx.xxx.xxx.xxx.

Now I have the same setup on another computer and I've never had an issue with any of this. Any thoughts?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

When you say that it works on another computer, do you mean another MacOSX machine, with the same OS version ? Because I had many problems with the latest versions of MacOSX since it doesn't come with Rosetta anymore. You may want to try "opennx" instead of the Nomachine client.

share|improve this answer
    
The weird thing is that I have no problem logging into another computer, running nx and freenx, from the same Mac. I'll give opennx a try. –  Przemek Lach Jan 28 '13 at 18:27
    
So I got rid of the NoMachine nxserver and instead installed neatx. I then used the opennx client as you suggested and voila everything works perfectly. I didn't have to setup any extra keys. I think with neatx as long as you can ssh into the computer, neatx just works out of the box which is very nice. Thanks for your suggestions. –  Przemek Lach Jan 28 '13 at 20:15
add comment

Can you ssh to the server? Is there a firewall enabled on the Linux side (iptables)?

Isn't the version of Nomachine in freenx older than what's available via the Nomachine website?

share|improve this answer
    
Yes I can ssh and iptables is enabled. I've installed no machine as you suggested and I actually get further this time; however, now it tells me that "Cannot start the requested session" and when I look at my logs on the client it says "NX> 595 ERROR: A fatal error occurred in NX Server." I looked at the logs on the server under /var/log/messages but they are too long to post here and I'm not sure how useful they would be. When Installing I just left everything as is and I copied the private key to my client for using the NoMachine login. –  Przemek Lach Jan 28 '13 at 8:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.