Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a CentOS 6 box with puppet 3.0.2.
The /etc/puppet/manifests/site.pp on the puppet server does not seem to do anything, so I ran:

puppet master --no-daemonize --logdest console --verbose --debug

And I get the following:

Debug: Using settings: adding file resource 'reportdir': 'File[/var/lib/puppet/.puppet/var/reports]{:ensure=>:directory, :backup=>false, :loglevel=>:debug, :links=>:follow, :mode=>"750", :path=>"/var/lib/puppet/.puppet/var/reports"}'

Debug: Using settings: adding file resource 'manifestdir': 'File[/var/lib/puppet/.puppet/manifests]{:ensure=>:directory, :backup=>false, :loglevel=>:debug, :links=>:follow, :path=>"/var/lib/puppet/.puppet/manifests"}'

etc.

It doesn't seem to be using /etc/puppet at all.
Is this normal?
How do I make it look under /etc/puppet?

share|improve this question
    
What's your /etc/puppet/puppet.conf look like? –  Shane Madden Jan 29 '13 at 4:56
add comment

2 Answers

This is the expected behaviour now according to Bug #16637. When running on the command line (as a non-root user) you will need to pass the --confdir parameter to override the default location of ~/.puppet/puppet.conf e.g.:

puppet master --confdir /etc/puppet --no-daemonize --logdest console --verbose --debug

If you have updated to Puppet 3 and had previously configured the Puppet Master to run within Passenger as a non-root user you will also need to update your config.ru file to supply these parameters e.g.:

# Rack applications typically don't start as root.  Set --confdir and --vardir
# to prevent reading configuration from ~puppet/.puppet/puppet.conf and writing
# to ~puppet/.puppet
ARGV << "--confdir" << "/etc/puppet"
ARGV << "--vardir"  << "/var/lib/puppet"
share|improve this answer
add comment

Try running puppet with the --confdir option. For example:

puppet master --confdir /etc/puppet
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.