Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 3 servers, a DC an exchange server and an apps server. If I ping the DC from any server or ping any server from the DC I get an IPv4 response, as you would expect, however if I ping exchange from apps, or the other way round the result I get is an IPv6 address.

All the NICs have IPv6 unticked so I can't understand why they are responding with these addresses, I also think this is causing problems because the Blackbery Enterprise Server I have just installed on apps cannot communicate with the Exchange server.

Any ideas how to get back to regular old IPv4?

The problem with BES resolving Exchange does seem to be an IP or DNS issue. If I use the IPv4 address of the exchange server in the BES MAPI setup it resolves that name to Exchange, and gets a connection, but then when you start BES it tries to resolve the name, and fails!

share|improve this question
    
As a Microsoft technician's reply to a recent windows issue: "Weird!". What steps did you take to disabling IPv6 on these servers? Can you ping localhost with IPv6? (ping -6 localhost) –  l0c0b0x Jul 28 '09 at 23:18

5 Answers 5

up vote 4 down vote accepted

are these actually responding on ipv6 or are they resolving ipv6. If they are resolving to IPv6 they might be cached or have ipv6 addresses registered in DNS.

I'd try (at the command prompt) running:

   ipconfig /flushdns
    nbtstat -R

then seeing if you have the same problem

share|improve this answer
    
In addtition also do nslookup to see what DNS is resolving to. –  Saurabh Barjatiya Jul 29 '09 at 9:21

If you want to just ping IPv4 (useful for finding the IP of a FQDN) then just tack a -4 onto the end of your ping request. Eg:

ping example.com -4

Doesn't really explain why you're getting IPv6 resolution when it's disabled though...

share|improve this answer

Ran into the same issue, resolved by deleting IPv6 entries in DNS server and then flushing dns (restarted clients for good measure).

share|improve this answer

i had a similar problem and i've disabled ipv6 by following this http://support.microsoft.com/kb/929852

in short create a DWORD entry named DisabledComponents in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\ and give it the value 0xffffffff

share|improve this answer

if you want to ping prefer by IPv4 over IPv6 following this http://support.microsoft.com/kb/929852/en-us and get fix it tool (Prefer IPv4 over IPv6 in prefix policies)

It's work for me.

share|improve this answer
1  
Welcome to ServerFault! It would be very helpful if you could include the basic steps from the content of the page you link to. Otherwise, if that page gets moved or taken down, your answer won't be very helpful. –  Jenny D Aug 8 at 10:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.