Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a new installation of Windows Server 2012 acting as a development server. I'm attempting to install DotNetNuke to a site, but when I run the install wizard, while the site comes up, static content is not being served (e.g., no images, CSS or JavaScript).

Static Content role is installed on the server, the StaticFileModule is installed, and the StaticFile handler is mapped to the StaticFileModule.

I created a test page with a sample image, but when I browse to it, I get "401 - Unauthorized: Access is denied due to invalid credentials." I've used IIS7 some in the past, but I understand permissions have changed for IIS8 (using the AppPoolIdentity instead of Network Services) so I don't if the problem is permissions or if I'm missing something else.

I created a new site with the same index.html and sample image and got the same 401 error. I've tried Google but there doesn't seem to be as much discussion on IIS8 on the net as yet.

Edit: Being an internal development server, as a test we added Everyone with Modify permissions to the DNN site, and now it works, so looks like most definitely a permissions issue. Perusing the DNN forums suggests setting AppPoolIdentity\AppPoolName to Modify, but that hasn't worked. I haven't been able to find much else, so my question now is what permissions for what user account do I need to make IIS8 and DNN play nice together?

share|improve this question

Giving Read access to AppPoolIdentity\AppPoolName should be sufficient.

I would use Process Monitor and filter for 'Access Denied' events to find out who exactly can't access the resources.

share|improve this answer

On the Authentication pane select Anonymous Authentication and then Edit.... If you see something like "IUSR" there try simply changing that to the Application pool identity option. Worked for me with exactly the same symptoms.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.