Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have serious performance issues with oracle running over ssd.

I have two OCZ Vertex 3 MAX IOPS drives (firmware 2.15). It runs on a INTEL C600 SATA Chipset. Windows 2008 R2.

So the issue is following.

When i put a Oracle redo logs on first sdd and the database file on other ssd a serious degradation happens on second sdd. I created a test table without any indexes primary keys, just for test purpose to simplify situation. It has a blob field and varchar field. I`m inserting data at max speed with 1kb to blob field.

And here what is happens: Oracle begins to write to redo logs at speed 30-40mb/s. And while its writing only to logs it works fine. Then Oracle stop write to redologs and write to database file at speed 40mb. Then it begin to write to redologs again. And after it the mystery is happens. It begin to write to datafile at speed of 2mb/sec ( ~200 iops) and that all. And from this point it will write to this sdd drive at this speed. If i open the disk from file manager it will be slow and if i try to copy file to it while oracle writing 2mb/s it will be verrry slow too. So it looks that ssd drives running on its limit but how that can happen? The SSD are more than half empty. I tried to switch redo logs and datafile drives and get the same result but with the other drive.

If i just copy file to ssd it show write speed ~600mb/s. There also two hdd drives in that system. So i tried to put redo logs on hdd and datafiles on ssd. And here what is happened. Write speed to redo logs was increased to 50-60mb/s(so the speed of inserts too. Why its slower on ssd??). But then again when it begin to write to ssd drive to datafile it will get same 2mb/s speed.

The next what i tried was to put redologs and datafiles on one ssd drive. And here miracle happened. It was writing to redologs first then to datafiles, but it was writing at 20mb/s sec speed to redologs and to datafiles, and no such behaviour with 2mb/s. So it work faster on one ssd than on two ssd. Why?

The next thing i tried was to put datafile on hdd and redologs on ssd. And it worked fine too, the write speed to datafile was 30mb/s.

So i'm out of idea what is happening and how to fix it and what wrong with my SSD.

share|improve this question
    
I haven't worked with oracle before, but I know you need to tune your OS for it. Have you read any articles on Oracle and SSDs? Also how is the file system formatted, 4k blocks? What does Oracle recommend, etc, etc. –  Danie Jan 29 '13 at 11:42
1  
Do you have the Write caching on? Try disabling it from the Device Manager, on the "Policies" tab for your SSD. –  grassroot Jan 29 '13 at 12:19
    
grassroot, wow. Big thanks. Disabling write cachin completely fixes the described situation, now ssd works a way faster. Please post it as an answer and i will accept it.. But i still dont understand how cache can lead to this 2mb/s performance. –  Aldarund Jan 29 '13 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.