Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just compiled and installed postfix and set domain names in main.cf.

Unfortunately postfix does not start. Nothing new shows up in the list of processes when I issue /usr/sbin/postfix start

echo $? gives 0

Are there any log files or other clues I could use to figure out what goes wrong? Thanks.

Which processes should I look for in the ps output?

Thanks.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

First, check to see that you're in a sane environment:

system-switch-mail
chkconfig --level 2345 postfix on

Next, find out what postfix seems to think the problem is:

service postfix restart ; tail -f /var/log/maillog

The startup failure will appear at the end of the log along with any clues as to why you're having an issue.

share|improve this answer
    
checking maillog (on different path set up by the hosting provider) showed that port 25 is taken. Turns out xinetd was set to listen on the smtp port. –  Evgeny Jul 29 '09 at 19:44
add comment

for starters look in /var/log/messages, it'll give you some clues on whats wrong and where to look, in most of the cases if you copy and paste error message into google you'll find either solution or some clues how to fix it

share|improve this answer
    
thanks. unfortunately there are no relevant messages –  Evgeny Jul 29 '09 at 1:13
1  
then try to put postfix into debug mode and try to start it like that –  alexus Jul 29 '09 at 16:10
add comment

Was there a specific reason you installed from source?

Why not just: yum install postfix

Then you will have a postfix init script.

chkconfig postfix on

service postfix start

If you need to switch from sendmail to postfix: yum install system-switch-mail

and then run:

system-switch-mail

to switch to postfix.

Hope this helps.

Cheers

share|improve this answer
    
i've tried the method you suggested before - same result. when I do start then stop the system tells me that postfix was not running. –  Evgeny Jul 29 '09 at 1:22
1  
Did you run system-switch-mail? Sendmail might be using some of the ports (e.g. 25). Run system-switch-mail. IIRC that will start postfix but you could issue a: service postfix restart to be sure. Cheers –  HTTP500 Jul 29 '09 at 3:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.