Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my local LAN, trying to share folders from my Linux Server to a Windows PC.

Samba daemon is listening:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      2707/smbd           
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      2707/smbd          

Samba looks well configured:

[root@localhost samba]# testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[Downloads]"
Processing section "[homes]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
    server string = My Lil Linux Box
    smb passwd file = /etc/samba/smbpasswd
    log file = /var/log/samba/%m.log
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    idmap config * : backend = tdb
    hosts allow = 192.168., 127.

[Downloads]
    comment = Downloads
    path = /home/samba
    read only = No
    guest ok = Yes

[homes]
    comment = My Home Directory
    read only = No
    guest ok = Yes

[printers]
    path = /var/spool/samba
    read only = No
    guest ok = Yes
    printable = Yes
    print ok = Yes
    browseable = No

Firewall has added exception for Samba and Samba client. Also disabled SELinux momentarily.

Nevertheless Windows PC can't discover this server, but server actually responds pings.

Any idea why I can't reach the Linux Server?

share|improve this question
1  
Did you try \\<server IP>\Downloads on windows machine? –  John Siu Jan 29 '13 at 15:19
1  
Can you reach it directly via the IP address (e.g. \\192.168.0.100)? –  Sven Jan 29 '13 at 15:20
    
I was following this... Yes those tips are the answer... Should I delete this question? –  jacktrades Jan 29 '13 at 15:22

1 Answer 1

up vote 2 down vote accepted

If \\<ip> works and is sufficient for you, all is fine. However, your problem is that the network browsing isn't working correctly. The easiest method to get this to work is often to just make sure both server and the clients are in the same SMB workgroup.

In Windows, you can setup the workgroup somewhere in the Control Panel->System -> System name or something (can't check right now). Make sure it has the same value on all machines and in your smb.conf in the [global] section you have a parameter

 workgroup = <workgroupname> 

which obviously should be the same as on the Windows machines.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.