Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just started using haproxy, so excuse me if I sound silly. haproxy itsekf is working fine and this is the config file that's in use:

# This file managed by Puppet
  chroot  /var/lib/haproxy
  group  haproxy
  log local0
  maxconn  4000
  pidfile  /var/run/
  stats  socket /var/lib/haproxy/stats
  user  haproxy

  log  global
  maxconn  8000
  option  redispatch
  retries  3
  stats  enable
  timeout  http-request 10s
  timeout  queue 1m
  timeout  connect 10s
  timeout  client 1m
  timeout  server 1m
  timeout  check 10s

listen nlb01
  balance roundrobin
  mode    http
  option  tcplog
  option  ssl-hello-chk
  option  httpclose
  option  forwardfor
  option  httpchk HEAD /check.txt HTTP/1.0
  server  apps01-uk-local check    
  server  apps02-uk-local check

In the web-gui, the status is always 'DOWN' even though nodes are running. Tried to search the forum and various other places in the web without having much of luck. Any idea what am I missing here? Thanks in advance for your help. Cheers!!

share|improve this question
What do you have in the LastChk column for the DOWN servers? – longneck Jan 29 '13 at 16:34
@longneck: L7STS/404 in 1ms and L7STS/404 in 1ms – MacUsers Jan 29 '13 at 17:10
up vote 2 down vote accepted

The LastChk column tells you what happened the last time haproxy tried to check the status of your server. In your case, the status of L7STS/404 means that the server returned a 404 error when attempting the check. Your configuration file says to look for check.txt. Does that file actually exist? If not, create it and problem solved!

share|improve this answer
Exactly!! it's fixed now. thanks!! – MacUsers Jan 29 '13 at 17:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.