Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've run into a problem connecting to my remote computer via Remote Desktop. I think it is a network configuration problem but am not sure what to check (or more appropriately, have the system guys check). Here is the situation:

When I try to connect to the remote computer from the main wired network at work I get the following error: Remote Desktop Connection error message

The network is not blocking outbound connections. From the wireless network here, I don't even get the error message, it just sits there trying to connect but doesn't do anything. I get the same effect if I use the IP address of the computer instead of the name.

I know that the computer I'm trying to connect to is properly configured to accept Remote Desktop connections since I was able to connect to it just fine last night from a third network (and a different computer) not associated with work and I'm the only one who connects to it. That rules out possibilities 1, 2, & 4 from the error message.

Any ideas on what the network problem could be that is causing this error?

share|improve this question

3 Answers 3

Are you getting any event log messages on the computer hosting the remote desktop connection (the "server")?

This article references a problem that I see fairly frequently with Windows XP machines hosting RDP: http://support.microsoft.com/kb/323497 Ignore that the article mentions Windows 2000-- I've absolutely seen this occurring on Windows XP-based computers more times than I can recall.

The classic symptom is an event ID 50 message, sourced from "TermDD", with the description "The RDP protocol component "DATA ENCRYPTION" detected an error in the protocol stream and has disconnected the client."

I've gotten so used to dealing with this (I'd love to know the exact circumstance that causes it) that I have the command to take care of it memorized:

REG DELETE HKLM\System\CurrentControlSet\Services\TermService\Parameters /v Certificate /f

Run that, reboot, and you'll find that the machine will correctly accept incoming RDP connections.

share|improve this answer
    
interesting idea but im not seeing where he says he is connecting to a Windows 2000 machine... –  djangofan Jul 29 '09 at 15:38
    
I've edited my posting. While I realize that the article references Windows 2000, as I stated prior (and now after) the link, this can and does happen on Windows XP-based RDP "servers", too. –  Evan Anderson Jul 29 '09 at 16:00

If this is the case of getting to your home PC from work it's could very well be a name resolution problem. What is between the XP machine you're trying to connect to and the machine you're trying to connect from? Is there a firewall (or two)?

Are you connecting via hostname or via IP address? Can you ping the XP machine?

Other things to check

  1. Double check that the firewall at your office is not blocking tcp port 3389
  2. If there's a firewall/router in front of your XP machine make sure it allows incoming connections on tcp port 3389 (and forwards them to your XP machine)
share|improve this answer

Try connecting with mstsc.exe /admin or ( mstsc.exe /console with older versions of TS) to get logged into the main console session. once your in, then use the Terminal Services manager to disconnect stray/idle non-console sessions. This allows you to get in when all the connections are used up. If that doesn't work then you can use Terminal Services Manager from a "server" computer on your network to manage the TS service remotely and kick off the sessions.

Q: also, in the Terminal Service settings, what is the encryption level set at on the server?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.