Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently set up my server using Centos 6, with ISPconfig 3 with httpd, php, mysql, mail server. I can create e-mail accounts in the control panel, And I successfully can log in to the webmail, I tried to send a message to my other e-mail on a other provider, And I received it, And tried to send a E-Mail to my server (example@myserver.net) , and The mail server responds, But refuses it with this back.

From:   
MAILER-DAEMON@teknikk.info  (Add as Preferred Sender)    
Date:   Tue, Jan 29, 2013 11:11 pm
To: contact@heisteknikk.com
This is the mail system at host teknikk.info.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<tek@teknikk.info>: unknown user: "tek"

Attached Delivery report

Reporting-MTA: dns; teknikk.info
X-Postfix-Queue-ID: CD9571A1312
X-Postfix-Sender: rfc822; contact@heisteknikk.com
Arrival-Date: Wed, 30 Jan 2013 00:11:00 +0100 (CET)

Final-Recipient: rfc822; tek@teknikk.info
Original-Recipient: rfc822;tek@teknikk.info
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "tek"

I set everything up with help from this guide, http://www.howtoforge.com/perfect-server-centos-6.3-x86_64-apache2-dovecot-ispconfig-3 No problems with the install, But somehow, The mail doesn't deliver to the account/s.


/etc/aliases

#
#  Aliases in this file will NOT be expanded in the header from
#  Mail, but WILL be visible over networks or from /bin/mail.
#
#       >>>>>>>>>>      The program "newaliases" must be run after
#       >> NOTE >>      this file is updated for any changes to
#       >>>>>>>>>>      show through to sendmail.
#

# Basic system aliases -- these MUST be present.
mailer-daemon:  postmaster
postmaster:     root
mailman:              "|/usr/lib/mailman/mail/mailman post mailman"
mailman-admin:        "|/usr/lib/mailman/mail/mailman admin mailman"
mailman-bounces:      "|/usr/lib/mailman/mail/mailman bounces mailman"
mailman-confirm:      "|/usr/lib/mailman/mail/mailman confirm mailman"
mailman-join:         "|/usr/lib/mailman/mail/mailman join mailman"
mailman-leave:        "|/usr/lib/mailman/mail/mailman leave mailman"
mailman-owner:        "|/usr/lib/mailman/mail/mailman owner mailman"
mailman-request:      "|/usr/lib/mailman/mail/mailman request mailman"
mailman-subscribe:    "|/usr/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe:  "|/usr/lib/mailman/mail/mailman unsubscribe mailman"
# General redirections for pseudo accounts.
bin:            root
daemon:         root
adm:            root
lp:             root
sync:           root
shutdown:       root
halt:           root
mail:           root
news:           root
uucp:           root
operator:       root
games:          root
gopher:         root
ftp:            root
nobody:         root
radiusd:        root
nut:            root
dbus:           root
vcsa:           root
canna:          root
wnn:            root
rpm:            root
nscd:           root
pcap:           root
apache:         root
webalizer:      root
dovecot:        root
fax:            root
quagga:         root
radvd:          root
pvm:            root
amanda:         root
privoxy:        root
ident:          root
named:          root
xfs:            root
gdm:            root
mailnull:       root

Tried to make a e-mail account named root@example.com and Did not get any errors, But didn't receive it in the inbox, But in the /var/spool/mail/root.

From ***********@gmail.com  Thu Jan 31 01:01:52 2013
Return-Path: <*********@gmail.com>
X-Original-To: root@teknikk.info
Delivered-To: root@teknikk.info
Received: from localhost (unknown [127.0.0.1])
        by teknikk.info (Postfix) with ESMTP id 083BF1A131E
        for <root@teknikk.info>; Thu, 31 Jan 2013 00:01:52 +0000 (UTC)
X-Virus-Scanned: amavisd-new at teknikk.info
Received: from teknikk.info ([127.0.0.1])
        by localhost (teknikk.info [127.0.0.1]) (amavisd-new, port 10024)
        with ESMTP id 2XRR49L51PYm for <root@teknikk.info>;
        Thu, 31 Jan 2013 01:01:51 +0100 (CET)
Received: from mail-vc0-f180.google.com (mail-vc0-f180.google.com [209.85.220.180])
        by teknikk.info (Postfix) with ESMTPS id B6C001A1314
        for <root@teknikk.info>; Thu, 31 Jan 2013 01:01:50 +0100 (CET)
Received: by mail-vc0-f180.google.com with SMTP id fo13so1371099vcb.25
        for <root@teknikk.info>; Wed, 30 Jan 2013 16:01:34 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:x-received:date:message-id:subject:from:to
         :content-type;
        bh=6+cGiWqC5rk7+tY2hOc3FkwVEvRIENfjOf46AqnjdGM=;
        b=kFz/YsQysZb99aGhpKYljBCTxwSaOBz6hd5wTs7iG/jLzw+Ib1KjpwA+GAS+e6HSkZ
         L5svGpK2/fQ5lSEp7H4xL49zOU9ATQ2zxLk3iihnhCnPhik4bsWzVwtMFWbkImGf+QQy
         MeK0LiZVY9Tc8ioeyNong9CQMzGZF8DVQxyo/3uXT6t5sc4dosoI9pCVtvsZX4aYLSHa
         YYInKpiE4j02dPGtDzOqoZulMTBWz2JGMC9m3iP0vM/EFSQQ4Me0HUcx1rglDa9Rafe4
         LAoRYHx2ctIaT15XOhDeQlyl1+MDV6TTbcd0rXDuJxl8q/I8BtPAcWpU5Sm00kq1/mIK
         BMsw==
MIME-Version: 1.0
X-Received: by 10.52.21.146 with SMTP id v18mr5586245vde.79.1359590494567;
 Wed, 30 Jan 2013 16:01:34 -0800 (PST)
Received: by 10.52.156.66 with HTTP; Wed, 30 Jan 2013 16:01:34 -0800 (PST)
Date: Thu, 31 Jan 2013 01:01:34 +0100
Message-ID: <CAPhR9Av=V3pvzU7k6WSRtXHQGDAmO1ObR0OOnW4c2GvjNMJX4Q@mail.gmail.com>
Subject: Grr
From: Andreas Teknikk <**********@gmail.com>
To: root@teknikk.info
Content-Type: multipart/alternative; boundary=20cf307ca38e77fe3004d48a540b

--20cf307ca38e77fe3004d48a540b
Content-Type: text/plain; charset=ISO-8859-1

Why doesn't the other accounts work?

--20cf307ca38e77fe3004d48a540b


Update

Was trying around things in the control panel, And added my other domain gametek.me to the e-mail [Domains] in ISPConfig, And created a test account

And tried to send a test mail to it using GMail, and suddently, It arrived, And then i tried my main domain teknikk.info, And then i got the Error User not exist, When it does exist.

So what I am wondering, Is it because the server hostname is my main domain, Cause I tried a different domain I had, and It worked with no problems ._.

I tried to delete the main domain from the cpanel, And readded it, And still didn't work.

So, If i use my main domain, The e-mails won't arrive, But If I use my second domain, It arrives.

I'm confused, Cause, Why does a other domain work, And not the main domain?

Cause I need to get it fixed, As I use my main domain for things.


Issue fixed

This problem is now fixed, Had to change the mydestination that postconf | grep ^mydestination Showed to a other, changed it to server1.example.com, and after that, I received the test mail's i sendt.

share|improve this question
1  
post the output of a netstat -tlupn | grep 25 –  Mike Jan 29 '13 at 23:26
    
Silly question i know, but does the user tek exist? Diagnostic-Code: X-Postfix; unknown user: "tek" –  Steve Jan 29 '13 at 23:28
    
@Mike [root@teknikk security]# netstat -tlupn | grep 25 tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 1917/master tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 1917/master tcp 0 0 :::25 :::* LISTEN 1917/master –  Teknikk Jan 29 '13 at 23:37
    
@Steve prntscr.com/qwc1y The CPanel is showing that The user I created does exist. –  Teknikk Jan 29 '13 at 23:39
1  
Im wondering if although ISPConfig thinks it has created the user, it hasnt actually been loaded into the postfix config.. im afraid i dont know enough about ISPconfig to comment. But the error Diagnostic-Code: X-Postfix; unknown user: "tek" really points to the postfix service not knowing about the user. –  Steve Jan 30 '13 at 10:13

1 Answer 1

up vote 1 down vote accepted

Is postfix configured to accept mail for the domain?

postconf | grep ^mydestination ?

I know it doesn't sound right because of the unknown user error, but it's worth checking.

share|improve this answer
    
Well, It says that my domain is in it. [root@teknikk web]# postconf | grep ^mydestination mydestination = teknikk.info, localhost, localhost.localdomain –  Teknikk Jan 31 '13 at 1:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.