Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First of all I would like to say it is my first message here and I'm not sure this the right place, I guess it us but... If it fits better in another stackexchange site please let me know.

It's three months ago I'm in charge of a cluster with six computers (Suse Linux 9.2) running a meteorological model in forecast mode. Recently because of a cut in the power supply one of the nodes crashed. After installing Lubuntu 12.04 (Suse 9.2 disks were not available, only 10.2) I tried to reconnect this computer to the cluster:

  1. Installed openssh server
  2. Run ssh-keygen to ssh without requiring password
  3. Installed NFS support
  4. Edited /etc/fstab
  5. Edited /etc/hosts

Then I tried to run the met model but got this error message:

rm_1993: p4_error: Could not gethostbyname for host thalassa; may be invalid name : 61
p0_12316: p4_error: Child process exited while making connection to remote process on thalassa3: 0

After Google searching I found some issues about /etc/resolv.conf and then edited this file:

domain ceam.es
dns-nameservers 192.168.1.1
nameserver 127.0.0.1

But the error message still appears. I assume I'm missing something, I am not an expert sysadmin but I have to deal with.

You can find error log, hosts and resolv.conf here.

Any help or idea will be greatly appreciated, I'll go on searching over the net for a solution.

Thanks in advance

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

First, you may need to remove this line from /etc/hosts:

127.0.1.1 thalassa3

because this way you get 2 IPs for a single hostname which /etc/hosts can't handle.

Then, having all the needed information in /etc/hosts, I'd rather blank /etc/resolv.conf to avoid ambiguity.

Regarding dns-nameservers 192.168.1.1 in /etc/resolv.conf.
As you can see in the comment at the beginning of file:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)  
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

you are not expected to edit this file by hand. According to the new rules dns-nameservers should be specified in /etc/network/interfaces, which will automatically propagate changes to /etc/resolv.conf (assuming you have resolvconf package installed). That is as per a server edition of Ubuntu OS. If you are by some reason using an installation with gui, you probably have to make these changes through Network Manager.

You might also want to check the contents of /etc/hostname to verify it is correct. If you edit it, you'll have to reboot to make changes persistent.

share|improve this answer
    
Thanks for answering @Pavel I'll remove the line from /etc/hosts. I don't edit resolv.conf by hand. I go to /etc/resolvconf/resolv.conf.d and edit "head". If needed, which changes are to be made in /etc/network/interfaces Content of /etc/hostname is a single line: thalassa3 –  pacomet Jan 30 '13 at 14:14
    
@pacomet, editing /etc/resolvconf/resolv.conf.d/head is not a very good idea. It is expected that resolvconf gathers this information from various sources including /etc/network/interfaces. Just add the dns-nameservers to the description of an interface. It should look something like this: auto eth1 iface eth1 inet static address 192.168.1.3 ... dns-nameservers 192.168.1.1. If you absolutely need to explicitly add something to /etc/resolv.conf you should write that to /etc/resolvconf/resolv.conf.d/base, which is intended for that. –  Pavel A Jan 30 '13 at 14:54
    
B/w, do you use the dns server at 192.168.1.1 to resolv the addresses of cluster nodes or just for the outer world? And one more point - you may have to change node name in /etc/hostname to thalassa3.ceam.es. Have you looked at how these files look on other cluster nodes? –  Pavel A Jan 30 '13 at 14:54
    
Thanks @Pavel ¡¡It's working now!! I restored the original head to resolv.conf and checked the content of /etc/network/interfaces in another cluster with Ubuntu. Now it is working fine. I'll add the file to the question so it could help other users. Regarding the dns server I just want to resolve the cluster nodes in thalassa3, only the central node connects to the outer world. –  pacomet Jan 31 '13 at 9:05
    
Glad, you have solved the problem. Just some more comments: 1. It looks little strange to me that you don't have auto eth0 just before the iface eth0 inet static line. The auto eth0 directive would allow the interface to be brought up at boot; 2. regarding the DNS server. In such case there is no need to specify DNS server settings on cluster nodes at all - you have all the required bindings set up in /etc/hosts. 3. If you don't mind, I'd ask you to post the final versions of these files: /etc/hosts, /etc/hostname and /etc/network/interfaces, so that we know how a working .. –  Pavel A Jan 31 '13 at 10:20
show 10 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.