Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to connect a backend server(gitorious running in https) to my frontend apache2 server running on ubuntu server. I believe that I have the vhost file and proxy config setup right but it still does not work as I am getting a 500 internal server error. I checked the error log and found what is below. I think it wants me to load other modules, I have enabled mod_ssl and proxy prior to this.

Does anyone know what modules it is asking me to enable or what might be the problem?

I found this standing out in the apache2 error log

[Wed Jan 30 17:53:43 2013] [warn] proxy: No protocol handler was valid for the 
URL /gitorious. If you are using a DSO version of mod_proxy, make sure the proxy
submodules are included in the configuration using LoadModule.

Just in case this is what is in my vhost file on the mainserver

 SSLProxyEngine On
 ProxyPreserveHost On
 ProxyPass /gitorious https://192.168.1.168
 ProxyPassReverse /gitorious https://192.168.1.168
share|improve this question
    
make sure the proxy submodules are included in the configuration using LoadModule: Did you include all of the required modules in the configuration file? There is more then one. –  Stefan Lasiewski Jan 30 '13 at 23:31

1 Answer 1

You need to enable the proxy module -

sudo a2enmod proxy_http

Then restart apache.

share|improve this answer
    
Thank you so much! –  user83438 Jan 31 '13 at 0:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.