Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am part of the administrator group on our domain but I have issues upgrading/installing software on my own account. I either have to get another administrator account to login and do it or shift + right-click -> run as other user and use their account.

What I have tried:

  1. Re-add to administrators group
  2. Drop computer off domain -> Change computer name -> Re-add to domain (make a new record in DC)

I know a solution would to be make a new account but I can't because I have other machines I log into that I would like to keep consistent.

whoami /all returns:

Any ideas?

share|improve this question

I'd be suspicious that a Restricted Groups Policy might be modifying the membership of your local Administrators group. Your disjoining / rejoining the domain and having this work as-expected for a short period supports that hypothesis.

I'd run a net localgroup administrators followed by a whoami /all from an elevated command prompt and compare the groups you're a member of to the groups that are granted local Administrators rights.


Per that output you are a member of the local Administrators group. What isn't working right for you?

share|improve this answer
Why the negative vote..? net localgroup administrators returns that I am an administrator. whoami /all returns – user157008 Jan 31 '13 at 18:09
I certainly didn't downvote you. I'll edit your question and add this image, though. – Evan Anderson Jan 31 '13 at 18:16
I dont have administrative rights to install programs/update. – user157008 Jan 31 '13 at 18:26
What kind of error messages are you receiving, specifically, when you try to perform what specific tasks? You definitely have Administrator rights per that whoami output. – Evan Anderson Jan 31 '13 at 18:27
some programs tell me i need to redo the install as an administrator, other just silently look like theyre updating but then close, and never update. but once I run the program as a different admin user it works fine. – user157008 Jan 31 '13 at 18:32

Are you sure your domain administrators group is in the local computer administrators group ?

share|improve this answer
Under the builtin > administrators I am in there. Builtin groups cannot be added to other groups. – user157008 Jan 31 '13 at 18:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.