Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Samba share to which I am copying files with robocopy /mir. Problem is the next time I try and sync that with robocopy /mir it copies all files again even though they haven't changed. I can't see why robocopy should be detecting all these files as changed when they haven't been.

Any ideas?

Thanks, Nick

share|improve this question
    
Check if the times matches with the local one for the remote file after the first copy run. –  Sven Jan 31 '13 at 17:17
    
Yep file times match but directories are replaced with the time of the copy. –  NickC Jan 31 '13 at 19:45
    
Now found a fix for that /dcopy:T but robocopy still detects all as Modified. –  NickC Jan 31 '13 at 20:15
    
Even checked permissions and they are the same, except for the 'Inherited from' description which is slightly different. –  NickC Feb 12 '13 at 16:43

1 Answer 1

If the original folder is formatted NTFS and the destination is EXT3 or EXT4 try the option /FFT (assume FAT File Times (2-second granularity)). NTFS and EXT* record time with different precision and that throws off the time match in robocopy.

share|improve this answer
    
Tried that but no difference. Currently using '/FFT /DCOPY:DAT /MIR' but all files still detecting as Modified –  NickC Mar 2 '13 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.