Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install icinga-web and I am getting following error:-

I tried installing both the icinga-core and icinga-idoutils but I still get this error.


apt-get install icinga-web
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 icinga-web : Depends: icinga-core (>= 1.7.0) but 1.6.1-2 is to be installed
              Depends: icinga-idoutils (>= 1.7.0) but 1.6.1-2 is to be installed
E: Unable to correct problems, you have held broken packages.

I did install icinga-core and icinga-idoutils

apt-get install icinga-core


Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  pkg-config libpthread-stubs0 libfontconfig1-dev x11proto-kb-dev xtrans-dev x11proto-input-dev libxpm-dev libfreetype6-dev libxau-dev xorg-sgml-doctools libx11-dev libx11-doc libxcb1-dev x11proto-core-dev libxdmcp-dev
  libpthread-stubs0-dev
Use 'apt-get autoremove' to remove them.
Suggested packages:
  nagios-nrpe-plugin
The following NEW packages will be installed:
  icinga-core
0 upgraded, 1 newly installed, 0 to remove and 117 not upgraded.
Need to get 0 B/287 kB of archives.
After this operation, 804 kB of additional disk space will be used.
Selecting previously unselected package icinga-core.
(Reading database ... 38940 files and directories currently installed.)
Unpacking icinga-core (from .../icinga-core_1.6.1-2_amd64.deb) ...
Processing triggers for man-db ...
Setting up icinga-core (1.6.1-2) ...
 * There is no configuration file for Icinga.
invoke-rc.d: initscript icinga, action "start" failed.

apt-get install icinga-idoutils


Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  pkg-config libpthread-stubs0 libfontconfig1-dev x11proto-kb-dev xtrans-dev x11proto-input-dev libxpm-dev libfreetype6-dev libxau-dev xorg-sgml-doctools libx11-dev libx11-doc libxcb1-dev x11proto-core-dev libxdmcp-dev
  libpthread-stubs0-dev
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  icinga-idoutils
0 upgraded, 1 newly installed, 0 to remove and 117 not upgraded.
Need to get 0 B/221 kB of archives.
After this operation, 1,442 kB of additional disk space will be used.
Selecting previously unselected package icinga-idoutils.
(Reading database ... 38947 files and directories currently installed.)
Unpacking icinga-idoutils (from .../icinga-idoutils_1.6.1-2_amd64.deb) ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Setting up icinga-idoutils (1.6.1-2) ...
dbconfig-common: writing config to /etc/dbconfig-common/icinga-idoutils.conf

Creating config file /etc/dbconfig-common/icinga-idoutils.conf with new version

Creating config file /etc/icinga/ido2db.cfg with new version
granting access to database icinga for icinga-idoutils@localhost: success.
verifying access for icinga-idoutils@localhost: success.
creating database icinga: success.
verifying database icinga exists: success.
populating database via sql...  done.
dbconfig-common: flushing administrative password

EDIT:

I just did a apt-get update and then apt-get install icinga

Adding outputs requested by @Zoredache

OS Version


Ubuntu 12.04 LTS (GNU/Linux 3.2.0-23-virtual x86_64)

apt-get cache policy icinga-idoutils


icinga-core:
  Installed: 1.6.1-2
  Candidate: 1.6.1-2
  Version table:
 *** 1.6.1-2 0
        500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

apt-get cache policy icinga-idoutils


icinga-idoutils:
  Installed: (none)
  Candidate: 1.6.1-2
  Version table:
     1.6.1-2 0
        500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
share|improve this question
1  
What is the output of apt-cache policy icinga-web, and apt-cache policy icinga-core? What OS/Release are you on? What repositories are you pointing to? Errors like that are almost always related to trying to mix and match repos improperly. –  Zoredache Jan 31 '13 at 20:25
    
@Zoredache Added the details. –  Sagar Hatekar Jan 31 '13 at 20:34
    
You added some details, but didn't include the details for the broken package icinga-web. –  Zoredache Jan 31 '13 at 20:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.