Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This scenario may seem a little weird at first ;) OS is Windows Server 2003.

We make a daily backup from our production servers and just copy the entire application to our backup servers, where we want an exact duplicate from the production environment (more or less).

This works pretty good, with one exception: The production system has to access some files on a share (ie. \\PROD_SHARE\Files$). This path is specified in a configuration file.

Now we don't want to change this config file when copying it to the backup server. Problem is, that the share path in the backup environment is different (this time it's on localhost, so the path is \\LOCALHOST\Files$).

Is it possible (on the backup server) to somehow "redirect" all requests to PROD_SHARE to LOCALHOST, so we can use the exact same config files as on the production environment? We tried it using the etc\hosts file, but it doesn't work (connection seems to work, but a login dialog appears and we can't login - maybe this is just some policy problem?).

Does anyone have an idea?

UPDATE:

Thanks for your answers so far, I think my question was far too complicated - actually, my problem is as easy as (my bad, sorry):

I want to be able to use \\PROD_SHARE instead of \\LOCALHOST (but the result should be the same)

I tried the answer with the alias name as well as with the LMHOSTS - both hat the same result as my first try with the HOSTS file: I can ping localhost using the different name, but when I try to open the SMB Share \\PROD_SHARE I get a login dialog (so the connection seems to work) where I can't login - even with the user credentials I just used to boot windows (Domain Admin). The error ist "Windows is unable to log you on. Be sure that your username and password are correct".

The production and backup environment are not in the same network/domain at all, so there shouldn't be any name conflicts.

share|improve this question

3 Answers 3

I haven't tried this, but maybe the LMHOSTS file would help?

It's like /etc/hosts for SMB server names. You can find it at %SystemRoot%\System32\Drivers\Etc (maybe it doesn't exist, but at least on Vista there is an lmhost.sam sample file).

share|improve this answer
    
    
Thanks a lot for your answer. Unfortunately it didn't work. Please see my reply below the original post. Tx! –  saxx Jul 29 '09 at 11:37

If I understand right, you want a machine in your backup environment to respond to the name of a server computer that's running in your production environment.

It's possible, but you may have some difficulties if there's NetBIOS communication between the backup environment and the production environment.

Here's the basic procedure for adding an alias name to a Windows Server machine.

  • On the backup server, add a REG_MULTI_SZ value named "OptionalNames" in the registry at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters. Put the name you'd like the backup server to respond to in that value.

  • Add a REG_DWORD value to the same registry key named "DisableStrictNameChecking" and set it to "1".

Bounce the "Server" service (or reboot the machine).

Where you may have a problem is that the backup server is going to try to register this alias name in WINS and will broadcast it using NetBIOS over TCP/IP. Since you already have a computer with the alias name running you may get "duplicate computer name" messages. If you can firewall your backup environment away from the production environment for NetBIOS then this will be a non-issue.

Also, be aware that there won't be any way to do Microsoft File and Print Sharing connections between the server with the alias name set and the real server computer using the NetBIOS name. You'll have to "connect" to the real server computer from the backup server by IP address if you need that functionality.

share|improve this answer
    
Thanks a lot for your answer. Unfortunately it didn't work. Please see my reply below the original post. Tx! –  saxx Jul 29 '09 at 11:38
    
You added "DisableStrictNameChecking" to the registry as well, correct? What service pack level are you on with the Windows OS on the "backup server"? –  Evan Anderson Jul 29 '09 at 12:09
    
I don't think the root cause of the problem is here (see above - the connection itself seems to work, the name can apparently be resolved). It's a Windows Server 2003 SP2 Web Edition –  saxx Jul 29 '09 at 13:50

I'm not sure if I've misunderstood the question or not, but I was wondering if maybe Microsoft DFS could be used in this scenario at all?

share|improve this answer
    
Thanks for the suggestion, but that would be oversized for our solution. Plus: The production environment should be left completely untouched. Tx anyway! –  saxx Jul 29 '09 at 11:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.