Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am a complete beginner in server management, however am put in a situation to manage our companies server running windows 2003. The person before me completely screwed up tons of stuff in this server (his "fix" for almost everything was to edit the registry), so there are all kinds of wierd things going on in this server.

I have recently added 4 new computers to our domain.

The first 2 computers were running windows 7 and were able to connect without a hitch at all.

The 3rd computer was a laptop that has always worked wirelessly but was never part of the domain, it connected to the domain, however even the main administrator login did not grant administrative rights. After a period of 2 days or so, this computer can now no longer log in at all, stating the error "windows cannot connect to the domain, either because the domain controller is down or otherwise unavailable, or because your computer account was not found."

The 4th computer is a brand new windows xp pro sp2 install on a clean formatted drive. After logging in, it is completely unable to connect to the domain, stating that the domain controller cannot be found, and that the DNS does not exist.

I have tried most of what I have found online on the 4th pc, including manually setting the DNS and IP of the computer, setting DNS records on the server, creating the computer and the user under SBSusers on the server in advance.

The problem PC's cannot ping the server by IP or hostname. All other pc's on our network (about 20) work properly.

share|improve this question
    
as a quick note, we close here in about 10 minutes, hoping to get some more info in for monday to try anything suggested. I might be able to get in a bit after close unofficially, but not sure. –  NRGdallas Feb 1 '13 at 22:58
    
"The problem PC's cannot ping the server by IP or hostname". Sounds like your question should be, why do the computers not have network connectivity to the server? –  Greg Askew Feb 1 '13 at 23:02
    
also a good question Greg - I have verified that the outlet works by connecting a different PC to the outlet, I have also connected the PC's at fault directly to the CISCO box in the server room. I have verified the cabling, and just about every other single possible hardware issue with connectivity. –  NRGdallas Feb 1 '13 at 23:20
    
If you cannot ping the server by IP, then you will never be able to connect to the domain. When you set the IP address on the PCs manually, are you sure you used an unused IP address that is routable to the server PC?. If you have 20 PCs I'm going to guess that all in a single subnet, probably something like 192.168.x.zzz, if so than the new ones need to be the same 192.168.x but the zzz must be unused anywhere else on your network. –  BillN Feb 2 '13 at 0:22
    
Also try pinging 127.0.0.1 on PC3&4 this will verify that the TCP stack is atleast installed and running on the client. –  BillN Feb 2 '13 at 0:23

1 Answer 1

up vote 1 down vote accepted

Edit: I missed the part where you say the client can't ping the DC by IP address. You have a routing or a switching problem or a client configuration problem, not an Active Directory problem.


All domain joined client computers should point to the domain controllers (and nothing else) as their DNS servers.

It sounds like you're not doing this on the problem machines.

Rule number one for troubleshooting AD problems is: it's always DNS

Rule number two is: if it's not DNS, look again, you missed the DNS problem.

share|improve this answer
    
It does seem to be routing/switching, but I have plugged another working PC into the exact same ethernet cable, and it works perfectly. Any ideas where I could start looking why only these 2 new PC's are not connecting? The laptop (3rd pc) has the same problem regardless of where it is connected, and both the 3rd and the 4th have been connected directly into the cisco box, and did not work. –  NRGdallas Feb 1 '13 at 23:54
    
It could be a client-side configuration or something like 802.1x. Really there's probably not a lot we can do for you with the level of detail here :( –  MDMarra Feb 1 '13 at 23:55
    
it could be client side, yes, but on 2 different clients, one of which is a brand new windows install, using both wired and wireless, and even when connected directly to the main switch? Any idea of some tests or anything on where to start looking? –  NRGdallas Feb 1 '13 at 23:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.