Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Gdal on my centos 6 machine with command

  yum install gdal

But when I try to run

$ ogrinfo 

I get following error

ogrinfo: error while loading shared libraries: libhdf5.so.6: cannot open shared object file: No such file or directory

Here is a output of

$ldd /usr/bin/ogrinfo

http://pastebin.com/piRg3MNr

(Since output was big passted on pastebin)

Repo list

adobe-linux-i386    Adobe Systems Incorporated                               
base                CentOS-6 - Base                                          
elgis               EL GIS 6 - x86_64                                        
epel                Extra Packages for Enterprise Linux 6 - x86_64           
extras              CentOS-6 - Extras                                        
google-chrome       google-chrome                                            
remi                Les RPM de remi pour Enterprise Linux 6 - x86_64         
remi-test           Les RPM de remi en test pour Enterprise Linux 6 - x86_64 
rpmforge            RHEL 6 - RPMforge.net - dag                          
updates             CentOS-6 - Updates
share|improve this question
    
Please give the yum repolist output. –  ewwhite Feb 2 '13 at 14:22
    
I have updated with repolist, I did not understood why downvote? –  m4k Feb 4 '13 at 7:17
add comment

3 Answers

Do you have libhdf5 installed? It's part of the hdf5 package.

Please run which ogrinfo and ldd /path/to/orginfo and post the output.

You need the libhdf5.so.6 file. It's part of hdf5.

Can just you run yum install hdf5 ?

share|improve this answer
    
When I do locate I get locate libhdf5 /usr/lib64/mpich2/lib/libhdf5.so.6 /usr/lib64/mpich2/lib/libhdf5.so.6.0.4 /usr/lib64/mpich2/lib/libhdf5_fortran.so.6 /usr/lib64/mpich2/lib/libhdf5_fortran.so.6.0.4 /usr/lib64/mpich2/lib/libhdf5_hl.so.6 /usr/lib64/mpich2/lib/libhdf5_hl.so.6.0.4 /usr/lib64/mpich2/lib/libhdf5hl_fortran.so.6 /usr/lib64/mpich2/lib/libhdf5hl_fortran.so.6.0.4 –  m4k Feb 2 '13 at 13:44
    
See edit above. –  ewwhite Feb 2 '13 at 13:47
    
I have added my output in my question. –  m4k Feb 2 '13 at 13:54
1  
You just need to install hdf5. See above. –  ewwhite Feb 2 '13 at 14:00
1  
Did you install hdf5? –  ewwhite Feb 2 '13 at 14:21
show 2 more comments

Maybe the database file /etc/ld.so.cache wasn't updated automatically try run ldconfig as root and see if it works now

share|improve this answer
add comment
up vote 0 down vote accepted

Resolved I had to install it again. This time I build it from source code.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.