Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install SmartOS on a new Supermicro server (SYS-6027R-N3RF4+). When I get to the screen to setup the admin interface, I see 4 interfaces, e.g., ifbg0, ifbg1, ... The status of these are all listed as unknown, and the Mac addresses do not match the mac addresses I use for IPMI. When I subsequently boot SmartOS I don't get a DHCP address, and ifconfig shows my IP as 127.0.0.1.

Is this a SmartOS config issue, or a Supermicro server issue? How do I resolve this, or test it?

share|improve this question
    
I'd have to look at how SmartOS "installs" these days to be sure, but last I looked it didn't "save" any configuration in the image (on your USB drive) and expects to receive it's configuration from an automated system on every boot. SmartOS is not meant to be a stand-alone OS, it's meant to be a component in a larger system. –  Chris S Feb 4 '13 at 2:44
    
@Chris. I think it saves config info in /usbkey/config . I can see my changes persist on reboots, and appear to be stored there. –  Andrew B. Feb 4 '13 at 2:55

1 Answer 1

Your IPMI mac address is distinct from your four main ethernet ports. By default IPMI is handled over it's own RJ45 jack. This means you will need to use one cable for IPMI and one for regular traffic. Depending on the board, you may or may not be able to pop into the BIOS and transparently bridge the IPMI traffic to the first Gigabit port (not recommended). If you log into the web interface of your IPMI port you can also see the mac address and statuses your four Gigabit NICs. I'd bet this has nothing to do with SmartOS, you're just used to Dell servers where the management port is bridged by default.

As for how to test: boot another operating system you're familiar with (Linux, Windows, etc) and if networking there doesn't work, it's SuperMicro hardware. If you think it's SmartOS, try booting something similar like OpenIndiana and see if it also shows the same issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.