Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using OpenVPN Access Server in Amazon VPC. I've used the custom AMI that has OpenVPN Access Server preinstalled.

My VPC is My public subnet is

OpenVPN Server: + ElasticIP Test Server:

VPN Subnet is dynamic and is the default

Once connection is established, my workstation (VPN client) gets an IP of On the VPN Server, ifconfig shows two related IPs:,

In Advanced VPN -> I've set "Should clients be able to communicate with each other on the VPN network?" to Yes.

I've set Access Server to route mode and it's nearly all working: From my workstation, I can connect to the VPN server and ping it on its private IP ( I can also ping and get replies to a server behind it on (I've set up a route in Amazon VPC admin console).

From the Access Server, I can ping my workstation IP on

However, from the server in Amazon VPC at, I cant ping my workstation at I do get ping replies from and

How do I set this up so that from I can ping my workstation at Have I misconfigured something in Access Server, or can't I set it up like that using the GUI?

share|improve this question

1 Answer 1

This turned out to be a Windows Firewall issue. I don't know why it was working when pings were initiated from the OpenVPN server itself, but pings initiated from another server inside Amazon VPC were reaching the Windows client, but being dropped at the Windows Firewall.

I didn't realise that when I thought I was disabling the Windows Firewall I was only disabling it for a particular network (the wrong network).

Thanks to OpenVPN support on IRC for their assistance ( Great product and great support, considering I'm only still evaluating and havent paid a dime.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.