Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using Windows Server 2012 Essentials.

I've got two ethernet ports. One is connected to a router which is connected to the internet. This portion of the network is fine. The router runs DHCP on the 192.168.1.x subnet, and provides a Company1 WiFi for guests, which does not have access to servers etc.

The idea is to have a second LAN, through the Windows server. I'm trying to use the .16.x subnet for this, but machines on teh 16.x subnet can't see the internet.

Port 1 is set to get settings automatically from the router.

Port 2 is configured as so: IP: Subnet: Gateway DNS:

This connection shows as limited connectivity on the server.

Clients are set to use as both gateway and DNS. The server provides DNS services and DHCP on the internal network interface. I suspect that either the DNS/Gateway settings on port 2 (Internal) are wrong, but I've tried everything I can think of.

share|improve this question
Who or what is supposed to provide Internet access to machines in the 192.168.16.x subnet? If you didn't configure the router to and didn't configure the server to, then of course they won't have Internet access. (Think about it, what would Internet servers see as the source IP address of connections they make? How would reply packets from the Internet get back to machines on that network?) Some device has to NAT for them. – David Schwartz Feb 4 '13 at 12:02
I've just discovered that, thanks. I figured server 2012 was intelligent enough to just route between the networks. I'm trying to use RRAS, but now I'm getting an issue whereby both my network interfaces are attached to the domain, so I can't set up remote access. Is it possible to configure NAT without this? – Jon Story Feb 4 '13 at 13:21
It is intelligent enough to just route between the networks. However, that won't give them Internet access. – David Schwartz Feb 4 '13 at 19:22

Solved it, so I'll leave this here in case anyone else has the same issue.

I needed to add the RRAS module (Routing and Remote Access), then configure NAT to translate the internal network onto the external IP.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.