Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've configured my postfix/amavisd-new/spam-assassin setup after this tutorial https://help.ubuntu.com/community/Postfix/DKIM. But now the problem is that all mails I send are double signed with two DKMI Headers, one before and one after the mail is sent to amavisd-new. How can I prevent this behavior?

share|improve this question

closed as off topic by mdpc, kce, MadHatter, Khaled, Dave M Feb 5 '13 at 13:20

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 4 down vote accepted

to disable milter processing after amavis, add to your master.cf in the after-amavis section

127.0.0.1:10025 inet    n       -       -       -       -       smtpd
[....]
-o smtpd_milters=

if you want to run the milter after amavis, set the smtpd_milters= configuration option in main.cf to an empty string and add the inet:localhost:8891 configuration to master.cf instead:

-o smtpd_milters=inet:localhost:8891
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.