Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a little bit of a story. I spilt hot chocolate on my lovely Lenovo Ultrabook and killed it. I fixed it and put a new keyboard in. Windows was running quite slowly so I went to do the Windows 8 reinstall because it was UEFI and it worked. Unfortunately within about 30 minutes it was at 2% so I gave up. Got a USB CD drive and tried to install it that way. There were like 7-8 partitions from my 1TB hdd which I removed.

Before I removed them I was getting an error about not being able to make a partition. Once I removed these I still got the error so I guessed it was the cache drive inside. So I took the cache drive out and Windows worked fine. I was silly. I backed up my documents to the Cache Drives partition which was formatted for Windows (not sure what format). This drive also is for Intel Rapid Storage Technology and there is a setting to turn it off in the BIOS. I've tried this. No luck.

Windows just saids Please Reformat D. I've tried DiskDigger, TestDisk, FixParts, GPart and no luck. They either report wrong size or IO error.

I really need my data back so if anyone could help me that would be amazing.

share|improve this question

closed as off topic by MikeyB, HopelessN00b, Ward, Khaled, Dave M Feb 7 '13 at 16:53

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Bit of luck. I turned on RST in my BIOS and GDisk now works. I have no idea how to recover my data with it though. – Jamie H Feb 5 '13 at 7:05
GDisk reports my MBR and GPT are protective and BSD and APM are not present – Jamie H Feb 5 '13 at 7:11
Does your disk have a backup GPT (it should on last logical block)? Could you try recover/boot from it? – Heis Spiter Feb 5 '13 at 7:13
The Cache has 2 partitions. The cache bit and the data one. How do I find my backup GPT? – Jamie H Feb 5 '13 at 7:15
It's normally on the last LBA of your disk. So, at its total end. No idea which tool could use it though. Windows (at least 2003) is able to handle a GPT device if only backup GPT is available. – Heis Spiter Feb 5 '13 at 7:18
up vote 0 down vote accepted

This isn't ideal but it was the only solution I could come up with.

I enabled Intel Rapid Storage in my BIOS. Booted up TestDisk and dumped the data partition to a RAW image. Mounted it using OFSMount and then used DiskDigger to get the data from the RAW Image. Unfortunately there are no file names but I have most of my data intact now.

share|improve this answer
Just found out you can mount an image file in DiskDigger reducing the need for OFSMount – Jamie H Feb 7 '13 at 14:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.