Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I don't know why am I getting a 404 error when I try to access to my site www.muisditee.com.

This is /etc/apache2/sites-available/default file, (as I enabled it, /etc/apache2/sites-enabled/default-000 is identical)

 <VirtualHost *:80>
            ServerAdmin admin@muisditee.com

            DocumentRoot /var/www/www.muisditee.com
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/www.muisditee.com/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>

            ErrorLog ${APACHE_LOG_DIR}/www.muisditee.com/error.log

            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn

            CustomLog ${APACHE_LOG_DIR}/www.muisditee.com/access.log combined
    </VirtualHost>

This is what I get with apache2ctl -S

/usr/sbin/apache2ctl: line 87: ulimit: open files: cannot modify limit: Operation not permitted
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server ns232323.mhostng.net (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost ns232323.mhostng.net (/etc/apache2/sites-enabled/000-default:1)
Syntax OK

My site of course exists at /var/www/www.muisditee.com and I have an index.html file there.

Both http:// www.muisditee.com and http:// www.muisditee.com/index.html give a 404 error. Anyone can give me a clue of what's wrong?

thank you

share|improve this question
    
what is the access log saying? and write right after the ServerAdmin in the next line ServerName www.muisditee.com –  zwarag Feb 5 '13 at 9:50
    
It's not being written in access.log –  de3 Feb 5 '13 at 10:01
1  
well apache2ctl -S will not start your apache. and if you do not have any entry in your access log, this means your apache never every recived a request. Probably because it wasnt running. you should try to start your apache (/etc/init.d/apache2 start) and try it again –  zwarag Feb 5 '13 at 10:07
    
tell me pls if it worked, so i'll write a answer ;) –  zwarag Feb 5 '13 at 10:30
    
Yes, it's a stupid question, I thought it was running... I am a newbie and touching many things –  de3 Feb 5 '13 at 10:42

2 Answers 2

up vote 0 down vote accepted

Well apache2ctl -S will not start your apache.
If you do not have any entry in your access log, this means your apache never every recived a request.
Probably because it wasnt running.
You should try to start your apache /etc/init.d/apache2 start and try it again.

share|improve this answer

Make sure you didn't include two virtual hosts with the same configuration:

<VirtualHost *:80>

says that "any domain pointing to this server, contacting me on port 80, should be served from here". If you have two identical lines Apache doesn't know which one to use. In your case Apache maybe loads the other one first which points to another directory?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.