Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I simply fail to set myhostname for postfix. I am running Debian 6.0.

I simply want to call:

postconf -e "myhostname = mail.mydomain.com"
service postfix restart

in order to prevent mails getting rejected by some servers for lacking fqdn hostname.

But it is simply ignored. My main.cf shows:

myhostname = mail.mydomain.com

But:

postconf -d myhostname

yields

<machine-hostname>.localdomain

just like before. As if I never changed anything.

What's the matter? ;) Any help appreciated.

share|improve this question
up vote 1 down vote accepted

Using postconf -d will show you the default value for the config parameter. Just remove the -d and use the following instead

$ postconf myhostname

and you should get the current value. See man postconf for more info.

share|improve this answer
    
Haha, thanks a lot. And sorry for my stupidity. Clear case of rtfm. – phlebas Feb 5 '13 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.