Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running svnserve on a server, but I can only access it with the svn+ssh protocol, not svn. (This appears to present a problem when I try to checkout from it with Capistrano.) Can anyone point out what might be wrong?

Svn's machine:

[root@machine ~]# service svnserve status
svnserve (pid  13166) is running...

Local machine:

$ svn info svn+ssh://root@<svnserver>.com/svnrepos/myrepo
-- returns fine
$ svn info svn://<svnserver>.com/svnrepos/myrepo
svn: E170001: Unable to connect to a repository at URL 'svn://<svnserver>.com/svnrepos/myrepo'
svn: E170001: No access allowed to this repository

I have even tried making use of the --username and --password params but have had exactly the same results.

UPDATE:

To set up Subversion, I followed the brief instructions to Setup a Subversion Server in 4 Minutes. My only deviation from its instructions was to kill the daemon svnserve process after I found it wasn't working for the svn:// protocol and then use service to start svnserve. (It likewise didn't work.)

share|improve this question
    
Did you check this topic already? –  Devator Feb 5 '13 at 15:42
    
@Devator, I'm checking it out now, thank you. –  JellicleCat Feb 5 '13 at 15:48

1 Answer 1

up vote 1 down vote accepted

Answering your question would be easier if you provide :

  • What you have done so far to make it work (eg set up svnserve, ...)
  • OS version.

Therefore, I'll make the following assumption :

  • Nothing has been done so far to make svnserve works
  • You are using RHEL (service status).

Here's an untested setup (from memory and man pages):

  • Edit /etc/sysconfig/svnserve
OPTIONS="--threads --root /path/to/svnroot"
  • Edit /path/to/svnroot/conf/svnserve.conf

[general]
anon-access = none
auth-access = read
password-db = passwd
realm = My First Repository
  • Edit /path/to/svnroot/conf/passwd

[users]
joeuser = joepassword
jayrandom = randomjay
share|improve this answer
    
Thank you much, sir. My failing was to set password-db in my svnserve.conf file. I actually have no file at /etc/sysconfig/svnserve, but one turns up at /etc/rc.d/init.d/svnserve. Might this file serve the same function? –  JellicleCat Feb 5 '13 at 15:50
    
As I still don't know about your distro, it's hard to guess –  coincoin Feb 5 '13 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.