Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hello I have Windows Server 2008 Enterprise. I need on system start up sync time. I'm user in administrators group. I've tried to add task to schedule. I give the task my account rights, but it not helps. It says that access denied. I need to run .bat file or w32tm /resync. But if I run the .bat file with context menu "Run as administrator..." everything is ok.

Any suggestions? Please!!

Thank's in advance.

share|improve this question

4 Answers 4

On the scheduled task properties, on the General page, did you check off "Run with highest privileges?"

share|improve this answer

You could also try to run it as System instead of your account. I had to do something like that with a task. To run it as System, since mine was on a DC, I had to export the task and in the XML I edited this part:

  <Principals>
    <Principal id="Author">
      <UserId>SYSTEM</UserId>
      <RunLevel>HighestAvailable</RunLevel>
   </Principal>

Where UserId was my username and now I've set it up for SYSTEM. Import the task and you should have that as the User and set it to Run with highest privileges.

Hope this helps.

share|improve this answer

I wouldn't even use a scheduled task. There are options within w32tm itself to set a specific interval for time sync. You can specify any time interval you want, for instance you could set your server to update it's time from your designated NTP servers every 5 mintues. Then your server would be in sync no matter what.

share|improve this answer

You don't need to configure a scheduled task to synchronise time.

If your server is not joined to a domain, it will automatically sync to time.windows.com. To make it sync with a different server, use this command in a command prompt window:

net time /setsntp:ntp1.example.net,ntp2.example.net

If your server is joined to a domain it will automagically sync to the nearest Domain Controller.

If your server is the Domain Controller which holds the PDC Emulator FSMO role, you must configure it to sync to another NTP server using the "net time..." command above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.