Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

At work our ISP has given us a block of IPs and I was wondering how I go about mapping them. Currently out setup is that the ISPs fiber goes into out router which is then routed throughout the office.

They have given us the following information...

new route
x.x.x.x/28
Subnet is: x.x.x.x/28 next-hop x.x.x.x
Usable IP Range: x.x.x.x - x.x.x.x
Gateway: x.x.x.x Broadcast: x.x.x.x Subnetmask: 255.255.255.240

I was wondering how I go about mapping this information to our router. I'm not expecting anyone to give me a step by step guided tour but what information I should be looking to set on the router's configuration.

Once setup is it possible to allow a computer on the network behind the firewall to utilize all of these IPs for binding requests to?

EDIT: The end goal is to have one server that can bind outgoing requests to different IPs assigned to me from the ISP. One and only one server needs this and it will be behind the router. It's currently running Windows Server 2008. It still needs to access internal network resources. So I don't need a specific IP to be routed to a computer internally. I just want to be able to bind a request to one of the IPs given to me from my ISP.

The router in question is a Cisco/Linksys RV016. You can find firmware emulator here... ui.linksys.com/files/RV016/1.2.3

share|improve this question
    
What type of router? –  Brandon Jul 29 '09 at 15:27
    
It's a Cisco/Linksys RV016. You can find firmware emulator here... ui.linksys.com/files/RV016/1.2.3 –  Chad Moran Jul 29 '09 at 15:32
    
Please search serverfault for subnet/subnetting. –  Kurt Jul 30 '09 at 6:57

6 Answers 6

up vote 1 down vote accepted

It sounds like you're looking to use one of your static IPs as the main public IP that outbound Internet traffic for your office uses, and then map a separate one of your public static IPs for use by the server? If that is the case, you'll just want to create a "one-to-one" NAT entry in the firewall. Using the emulator link you provided, it would be under the Setup -> One-to-One NAT. This basically associates one of the external IPs to an internal IP address.

Assuming your ISP is providing you a "bridged" connection (so that you can assign the public IP info directly to your firewall), you'll basically plug in the IP info into your firewall. Assuming you can access the Internet, the router will typically route all traffic outbound via the IP address you assign to it. If you have one-to-one NAT enabled, those hosts should communicate via a secondary IP.

Does that answer your question?

share|improve this answer

Assuming you are given 10.1.1.0/28 by your ISP, (used 0 to save calculation overhead :)) with gateway as 10.1.1.1 and broadcast 10.1.1.15 and netmask as 255.255.255.240. You can give IP address 10.1.1.2 (the first available IP to router) and set default route of router to the gateway, that is 10.1.1.1. This would allow router to access internet. Trying pinging IPs like 4.2.2.2 from router and you should be able to see response.

Once that is done you can configure NAT on router so that requests for IP 10.1.1.2 get forwarded to internal IP of the server.

This is too vague you would have to learn how to do above things

share|improve this answer
    
I apologize for not being entirely clear. I just want the IPs to be available for use on binding outgoing requests to them. I don't need incoming requests to be routed anywhere. –  Chad Moran Jul 29 '09 at 15:37
    
Then you just have to set default gateway of inside machines to routers internal IP. Routing will be taken care of by router. The only issue is you would be wasting lot of IPs as router would use its own public IP for sending requests. So about 13 IPs will remain unused. –  Saurabh Barjatiya Jul 30 '09 at 4:19

Well first the router is going to need an IP address, so you should configure it for a static IP.

I would recommend you keep NAT going for security reasons, and then if you need to forward outside traffic, set up a pinhole through NAT. Your router should let you map IP's to inside NAT addresses if you need multiple services (like RDP) going to multiple clients.

Otherwise you would set up the router just as a gateway and either set up DHCP to assign those addresses out or set up internal static IP's on the machines with the router as the gateway.

share|improve this answer
    
Basically I just need 1 server that has access to the IP range given to me by our ISP. The rest of the workstations/servers can use the normal IP. I was just wondering how I got about mapping the information they gave me on my router so one of our servers can use all of the IPs assigned to us. –  Chad Moran Jul 29 '09 at 15:00
    
Ah in that case, you can just plug the server directly into your ISP's router and give it a static IP address. Another option you could try if you still want to use the Linksys router is to set up one-to-one NAT or put it in the DMZ. –  Adam Brand Jul 29 '09 at 15:50

Are these bits of a Cisco config of any use to you at all?

!
ip dhcp pool <pool name>
   import all
   network 10.0.0.0 255.255.0.0
   dns-server <dns servers>
   default-router 10.0.0.1
   lease 0 2
!
!
ip domain lookup source-interface Dialer0
ip name-server <ns1>
ip name-server <ns2>
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode ansi-dmt
!
interface ATM0.1 point-to-point
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
!
interface Dot11Radio0
 no ip address
 ip nat inside
 ip virtual-reassembly
 !
 ssid <wireless name>
    vlan 10
    authentication open
    guest-mode
 !
 speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
 no cdp enable
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 ip address 10.0.0.1 255.255.0.0
 ip nat inside
 ip virtual-reassembly
 no cdp enable
!
interface Dialer0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname <chap username>
 ppp chap password 7 <chap password>
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip nat pool NAT_GROUP <starting IP> <ending IP> netmask 255.255.255.240
ip nat inside source list 10 pool NAT_GROUP
!
access-list 10 permit 10.0.0.0 0.0.255.255
dialer-list 1 protocol ip permit

This is the config used for an ADSL router that has been allocated a bunch of public IP addresses. These addresses are then NAT'ed 1:1 to an address within the 10.0.0.0/16 range on the wireless interface

This may, or may not, give you something to start with. Not knowing the make of router in use, it's hard to tell :)

share|improve this answer

From your question it looks like you are not 100% familiar with IP addressing. (Or I did get you wrong.)

You got only one network from your ISP. So those IP addresses have to be within the same Layer 2 domain. But what you want is to have different networks. Like this:

internal network -> Firewall -> external network 1 -> Router -> external network 2 -> Internet

The external network 2 is the one provided by the ISP.

If you want to put the firewall within this network then you have to place a switch in front of the router. And connect the firewall directly to it. But then is the question why you still need the router.

If you want to have the router in there you will need to either use NAT (to hide external network 1, which will then become an internal network) or you have to ask you ISP to give you a second IP range.

To clarify my wordings:
internal network = private IP addresses/range
external network = public IP addresses/range

And the last question: With firewall do you mean the server you are mentioning later? Or how many devices should have public IP addresses at the end?

share|improve this answer

i have a simple sloution

if you are given a pool of 8 ips, six of them are useable for you, like if u r given xxx.xxx.xxx.76-xxx.xxx.xxx.83 xxx.xxx.xxx.76 and xxx.xxx.xxx.83 are not useable for u.

if u have a ppoe connection with isp...configure ur router like this

connection type: PPOE username: xxxxxxxxxxx Password: xxxxxxxxxx

LAN Configuration

LAN IP: xxx.xxx.xxx.77 Subnetmask: xxx.xxx.xxx.xxx

DHCP: Disabled


now take a wire out from ur router and insert it in a lan card of ur server and gv that lan card ip IP xxx.xxx.xxx.79 Subnet: xxx.xxx.xxx.xxx Gateway: xxx.xxx.xxx.77 DNS: xxx.xxx.xxx.77 DNS2: (ur isp's DNS) if required

same ur can use ur rest of ips.......if ur like.....

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.