Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have trouble with dns server at CentOS. I have domain, I have bought it from

I added glue record to this domain . I configured nameservers with and . And IP address of this subdomains is which I configured at godaddy. is ip of my VPS.

Now I want to configure dns server at CentOS.

My configuration is this /etc/named.conf

// named.conf
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
// See /usr/share/doc/bind*/sample/ for example named configuration files.

options {
    listen-on port 53 {;; };
    listen-on-v6 port 53 { ::1; };
    directory   "/var/named";
    dump-file   "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
    allow-query     { localhost; };
    recursion yes;
allow-recursion {;;};

    query-source address * port 53;

    dnssec-enable yes;
    dnssec-validation yes;
    dnssec-lookaside auto;  

    /* Path to ISC DLV key */
    bindkeys-file "/etc/named.iscdlv.key";

    managed-keys-directory "/var/named/dynamic";

logging {
        channel default_debug {
                file "data/";
                severity dynamic;

zone "." IN {
    type hint;
    file "";

zone "" {
type master;
file "/var/named/";

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";

And domain zone file is this . /var/named/

$ttl 38400

@                 IN SOA (
100     ; serial
1H      ; refresh
1M      ; retry
1W      ; expiry
1D)     ; minimum      86400   IN      A      86400   IN      NS      86400   IN      NS

ns1  86400   IN      A

ns2  86400   IN      A

www      86400   IN      A

The problem is domain not working . I have checked many nslookup servers . my domain cannot resolved . What is wrong in my configuration?

share|improve this question
As an aside, having "two" nameservers that are hosted from the same BIND instance is somewhat missing the point. – nickgrim Feb 6 '13 at 10:13
Unless you're expecting to receive email at, I don't think your SOA is correct. – nickgrim Feb 6 '13 at 10:16 just now found your glue records ok, but gives an error of "The server refused our query". – nickgrim Feb 6 '13 at 10:18
Have you checked your firewall? – mgorven Feb 6 '13 at 19:57
I have found problem. tank you – Taleh Ibrahimli Feb 14 '13 at 11:20

1 Answer 1

I have found issue . issue is at this line

allow-query     { localhost; };

For remote access to binding server , this line must be fallowing

allow-query     { any; };

This replacement solved this problem

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.