Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had installed phpmyadmin in my Redhat Linux server machine (64bit). After installation when I tried to access the same with the URL domain.com/phpmyadmin, it is showing an error:

The requested URL /phpmyadmin/navigation.php< was not found on this server.

then I tried to access domain.com/phpmyadmin/setup, it is showing this error:

<?
/* @license http://www.gnu.org/licenses/gpl.html GNU GPL 2.0 */
/**
 * Core libraries.
 */
require './lib/common.inc.php';
$page = filter_input(INPUT_GET, 'page');
$page = preg_replace('/[^a-z]/', '', $page);
if ($page === '') { $page = 'index'; }
if (!file_exists("./setup/frames/$page.inc.php")) {
  // it will happen only when enterung URL by hand, we don't care for these cases
  die(__('Wrong GET file attribute value'));
}

// Handle done action info
$action_done = filter_input(INPUT_GET, 'action_done');
$action_done = preg_replace('/[^a-z_]/', '', $action_done);
// send no-cache headers
require './libraries/header_http.inc.php';
?>

and below this error only displaying "phpMyAdmin setup" and that's all. Also I had a try to access phpinfo.php in phpmyadmin folder and its showing a blank page.

Websites pages with PHP are working fine.

share|improve this question
    
Hello,welcome, please try improving your question so we can try to help you : Is it rhel 6? How did you try to install phpmyadmin eg yum install phpmyadmin or followed tutorial at foobar.example.com ? –  coincoin Feb 6 '13 at 13:21
    
thanks for the quick responce. yes its rhel 6, and i tried tarball and when it throwed the same error i just tried yum install also. i followed this link –  Renju chingath Feb 6 '13 at 13:47
    
Can you provide apache configuration and logs please? –  coincoin Feb 6 '13 at 14:22

1 Answer 1

up vote 0 down vote accepted

in my case, httpd.conf was causing issues. when i removed virtual servers created through webmin, got it worked. and reconfigured the same.

NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin admin@ebugs.com
    DocumentRoot "/usr/local/apache2/docs/ebugs"
    ServerName ebuqs.com
    ServerAlias www.ebugs.com
    ErrorLog "logs/ebugs/error_log"
    CustomLog "logs/ebugs/access_log" common
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin admin@startfromthegrub.com
    DocumentRoot "/usr/local/apache2/docs/startfromthegrub"
    ServerName startfromthegrub.com
    ServerAlias www.startfromthegrub.com
    ErrorLog "logs/startfromthegrub/error_log"
    CustomLog "logs/startfromthegrub/access_log" common
</VirtualHost>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.