Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i know there are a few threads about this already but they don't seem to fix my problem.

I've got a Ubuntu Server running Plesk11 with POSTFIX Server as email engine.

My primary domain - lets call it mydomain.com is hosted at united-domains and is pointing with A & MX Records to my Plesk server.

In my plesk server i am hosting the mydomain.com to run the webpage but the e-mail service is seperate in my network using Microsoft Exchange server.

So now when i try to send E-Mails to xxx@mydomain.com the server instantly replies with

mail for mydomain.com loops back to myself

also the system e-mails like root@mydomain.com coming from plesk itself aren't delivered properly anymore.

The whole thing started to escalate as i set a PTR record on our static ip pointing back to the plesk server.

What i want is, when i am sending an e-mail from a domain hosted on plesk to mydomain.com (website also hosted, but e-mail service deactivated) for the server to go out to the internet, check the MX records properly and send them to the exchange server (not locally) but i just keep getting that annoying error

Hope for you guys advice - is there any chance i can force Postfix to "ignore domain here, look for records at the internet" - even my DNS Entries in plesk itself point to a different ip.

share|improve this question

2 Answers 2

If you do not need a DNS server for your domain, you can disable it. In addition, disable the mail service for this domain too. It solved the problem for me.

Go to your domain administration page in power user mode. Then click on "DNS parameters". Then, click on "Disable the DNS service". Then, in the mail, click on "change parameters" and uncheck the "Activate the mail service" box.

share|improve this answer

If you deactivated the mail service in Plesk, configuration should be ok.

The problem seems to be your DNS configuration: Plesk will try to connect to the IP from the MX-record when no mail service for the domain is configured, so the MX record should point to your exchange server. In order to get your Plesk not mixed up, the PTR record of your exchange IP should be something else than mydomain.com (e. g. mail.mydomain.com).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.