Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My fedora 17 linode VPS shows an incorrect time.

The current real time in Dublin is 15:13 but my linode shows the time below which is out by 3 hours and 45 minutes:

cg@lin:~$ ls -l /etc/localtime
lrwxrwxrwx 1 root root 24 Feb  6 11:26 /etc/localtime -> /usr/share/zoneinfo/Eire
cg@lin:~$ date
Wed Feb  6 11:28:49 GMT 2013

Is there an additional step in setting the timezone in Fedora that I'm not aware of?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You need to have NTP installed, configured and turned on.

sudo yum install ntp
sudo systemctl start ntpd.service 
sudo systemctl enable ntpd.service 
share|improve this answer
    
Hmmm....how does this set the timezone which was the original question. It does set the time properly but does not change the timezone. –  mdpc Feb 6 '13 at 17:32
1  
The timezone is correct, compared to system time, he's asking why system time is not correct, ntp will set the system time correctly, and the localtime will adjust that to his timezone.. –  NickW Feb 6 '13 at 17:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.