Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have configured exim to work with dovecot (might be useful to point out) in both IMAP and SMTP auth. I need to make exim require STARTTLS + CRAM-MD5 when a client authenticates to send an email through it, but not for receiving.

I have tried many configuration options, including client_condition = (empty) in both LOGIN and PLAIN authenticators. With no luck.

How can I do this?

share|improve this question

You need to set

auth_advertise_hosts = ${if eq {$tls_cipher}{}{}{*}}
share|improve this answer
    
If I do that I get a “Relay not permitted” error when trying to send emails. Know why is that? – Mario Feb 11 '13 at 18:17
    
You need to make a TLS or SSL connection, and authenticate – topdog Feb 12 '13 at 13:30
    
My Thunderbird is configured to use STARTTLS for SMTP. Is that OK? – Mario Feb 12 '13 at 13:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.