Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've ran into an issue where several servers that I've been trying to migrate to different datastores the past few days are unable to migrate properly. Rather than migrating like normal, the servers are receiving failed attempts to migrate and show the following symptoms:

-The .vmx and some vmware.log files have duplicates in the original datastore and the new one I want to move it to.

-Each time I right click to view one of these VMs, I notice that the complete migration option is available but doesn't work.

-Each time I right click to view one of these VMs, I also notice that Power and Snapshot options are disabled.

Also I've noticed something about a dMotion inside one of the datastores, however I've never seen this before and was not sure what to do. After trying various different things I tried deleting it to see if that could be the problem, however it did nothing. At the moment, I'm trying to learn how to fix this by using an older VM that if it gets wiped by accident, there will be no harm done, that way I can then fix VMs that are being used and having this problem later.

If someone could help me fix this I'd appreciate it. I've been using the following KB article from VMware that I found doing some research, however I'm not too sure on some of the instructions since this is my first time doing this. Below is the link:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1009113

Thanks in advance!

share|improve this question
    
can you describe how you are trying to migrate the servers? are you migrating the vmdk (storage only: dmotion) or live-migrating the vms(vmotion)? are you using vcenter? –  Daniel t. Feb 6 '13 at 21:24
    
I've tried various methods by now. I just now tried manually moving the vmdk from one datastore to another and deleting the duplicate vmdk, however this did nothing to alleviate the errors. I'm migrating just the storage though, and through vCenter. –  Valrok Feb 6 '13 at 21:29
    
More detail on the setup. What type of storage are you using? Is the process failing at a particular percentage indicator? –  ewwhite Feb 6 '13 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.